Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 711018 - xfce-utils xinitrc sets GTK_PATH which confuses themes multilib
Summary: xfce-utils xinitrc sets GTK_PATH which confuses themes multilib
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce-utils
Version: 15
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-06 08:55 UTC by Jens Petersen
Modified: 2011-06-24 03:35 UTC (History)
2 users (show)

Fixed In Version: xfce-utils-4.8.2-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-24 03:35:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Xfce 7483 None None None Never

Description Jens Petersen 2011-06-06 08:55:43 UTC
Description of problem:
xfce-utils' xinitrc file sets GTK_PATH to ":libdir/gtk-2.0".

This seems to break the gtk theming of 32bit gtk apps on  x86_64.

How reproducible:
every time

Steps to Reproduce:
1. run 32 bit gtk application on x86_64 xfce desktop
eg remove gtk2-devel.x86_64 and install gtk2-devel.i686
and run gtk-demo.
2. $ printenv GTK_PATH
  
Actual results:
1. Uses the gtk fallback theme (looks like a 90's motif application;)
2. GTK_PATH=:/usr/lib64/gtk-2.0

Expected results:
1. To use the default gtk theme
2. GTK_PATH to be unset

Additional info:
I used gtk-demo from gtk2-devel.i686 to reproduce.

$ GTK_PATH="" gtk-demo

is ok

Comment 1 Jens Petersen 2011-06-06 09:17:51 UTC
As noted in the upstream report this also breaks loading of 32bit gtk3 modules for multilib.

Comment 2 Jens Petersen 2011-06-06 10:04:43 UTC
This package:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3112756

fixes the problem for me.

(BTW I think the pulseaudio patch is not actually doing anything:
it needs to be applied to xinitrc.in.in to actually get into
the final xinitrc and not be overwritten, if pulseaudio is wanted.)

Comment 3 Kevin Fenzi 2011-06-07 04:16:13 UTC
Interesting. 

Are there real life cases? Where did you run into this out of curiosity... ;)

Comment 4 Jens Petersen 2011-06-08 09:07:48 UTC
Sure - eg 32bit browsers on x86_64...

Comment 5 Jens Petersen 2011-06-08 09:09:39 UTC
A better patch that might make upstream happy would be
perhaps to set GTK_PATH only if @libdir@ != %{_libdir} say.

Comment 6 Fedora Update System 2011-06-18 13:10:25 UTC
xfce-utils-4.8.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xfce-utils-4.8.2-1.fc15

Comment 7 Fedora Update System 2011-06-21 17:37:12 UTC
Package xfce-utils-4.8.2-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce-utils-4.8.2-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xfce-utils-4.8.2-1.fc15
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-06-24 03:35:53 UTC
xfce-utils-4.8.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.