Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7096 - "autofs start" may attempt to run spurious commands
Summary: "autofs start" may attempt to run spurious commands
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autofs
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-18 09:15 UTC by David Carter
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-02 14:26:20 UTC


Attachments (Terms of Use)

Description David Carter 1999-11-18 09:15:53 UTC
If "/etc/auto.master" contains:

  /home   yp:auto.home    --timeout 60

then "/etc/rc.d/init.d/autofs start" complains:

  sh: yp:auto.home: command not found

Closer investigation suggests that the problem is at line 59 of the
init.d file:

  if echo $map | grep -- ':' ; then
                            ^ should have >/dev/null 2>&1

Comment 1 Nalin Dahyabhai 2000-02-02 14:26:59 UTC
This should be fixed in autofs-3.1.4 and later, in Raw Hide.  Please try this
version and reopen this bug if you continue to experience this problem.


Note You need to log in before you can comment on or make changes to this bug.