Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7075 - iBCS segmentation violation SCO binary
Summary: iBCS segmentation violation SCO binary
Keywords:
Status: CLOSED DUPLICATE of bug 6951
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-17 13:35 UTC by Brent R Brian
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-06 05:41:35 UTC


Attachments (Terms of Use)

Description Brent R Brian 1999-11-17 13:35:55 UTC
SCO 3.2.4.2 static binary, Business Basic, Basis Intl.

Runs fine under emulation RH 5.2, and runs on RH 6.1
(if installed as an upgraded from 5.2).

Failure occurs under a FRESH INSTALL of RH 6.1 with a

	"segmentation violation"

I have installed kernel-ibcs and re-'make'd the file, but
I get compile errors until x286 is turned off.  After a
successful compile I get the same thing.

Comment 1 Brent R Brian 1999-11-30 13:42:59 UTC
I did a fresh install of 5.2, iBCS worked well.
Rebuilt the kernel (pentium on, math emul off), still worked.
I upgraded 5.2 -> 6.1, iBCS still worked well.
I did a fresh install of 6.1, iBCS gives segmentation violation.
I RPM'd the kernel-ibcs source, followed the 'make' instructions,
  it still did not work.
Rebuilt the kernel, (pentium on, math emul off), still did not work.
I have compared the MAKEDEV.ibcs, they are the same.

Can I check anything else to help things along ??

B

Comment 2 Brent R Brian 1999-12-15 15:39:59 UTC
I found the following error during the compile of iBCS

binfmt_elf.c >> line 502: <<

	retval=namei(elf_interpreter,&interpreter_inode);

too many arguments.  The rest of the code uses a single
argument (filename).

Comment 3 Cristian Gafton 2000-01-04 22:20:59 UTC
Assigned to dledford

Comment 4 Bill Nottingham 2000-02-06 05:41:59 UTC
*** This bug has been marked as a duplicate of 6951 ***


Note You need to log in before you can comment on or make changes to this bug.