Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 70742 - Anaconda Crash: invalid literal for LONG() during installation
Summary: Anaconda Crash: invalid literal for LONG() during installation
Keywords:
Status: CLOSED DUPLICATE of bug 66181
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-04 17:55 UTC by Need Real Name
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-08-04 17:55:24 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-08-04 17:55:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
When reinstalling RH7.3 on a machine I previously had problems installing RH 
on, in fact ive installed the same distribution from the same installation 
disks on this machine 3 times now... the machine hangs after selecting packages.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Select packages
2.When Anaconda starts configuring it crashes
	

Actual Results:  An unhandled exception occurs.
Traceback (innermost last)
File "/usr/bin/anaconda", line 633, in ?
intf.run(id,dispatch,configFileData)

File "/usr/lib/anaconda/gui.py",line 353, in run
self.icw.run(self.runres,configFileData)

File "/usr/lib/python1.5/site-packages/gtk.py",
line 2676, in mainloop
_gtk.gtk_main()

File "/usr/lib/anaconda/gui.py" line 529
in handleRenderCallBack
Self.currentwindow.rew
.
.
.
File "/usr/lib/anaconda/fsset.py", line 211,
in badblock device

Val=(long(i[0])*100)(long(i[1]))
ValueError: Invalid literal for long(): 361428
361429

Expected Results:  Installation should have proceeded as usual.

Additional info:

I believe the problem might be a new Memorex Thirty-two max CDR that I am using 
to read the installation disks from.

Is there anyway besides swapping the CD drive to remedy this situation?

Comment 1 Michael Fulbright 2002-08-05 15:33:48 UTC
The bad blocks check found bad blocks on the drive being tested - the installer
crashes because it did not handle that exception correctly.



*** This bug has been marked as a duplicate of 66181 ***


Note You need to log in before you can comment on or make changes to this bug.