Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7043 - Gnome Terminal prompt
Summary: Gnome Terminal prompt
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs
Version: 6.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
: 6072 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-16 13:34 UTC by andrew.pickin
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-29 19:51:33 UTC


Attachments (Terms of Use)

Description andrew.pickin 1999-11-16 13:34:51 UTC
After running vi in a gnome terminal, the terminal's prompt is prefixed
with as 'c'.
This does not happen with the graphical '-g' option with vim.
Does happen with vim 5.4 rpm and 5.5 built from source.
It does not affect regular xterms.

Example:

[root@royals init.d]# vim
c[root@royals init.d]# vi -v
c[root@royals init.d]# PS1='> '
> vi
c>

Comment 1 Havoc Pennington 1999-11-17 21:40:59 UTC
I can reproduce this, but I have no idea what causes it.
I'm sending it upstream to the gnome-terminal author to
see what he thinks.

Comment 2 Havoc Pennington 1999-11-29 17:06:59 UTC
*** Bug 6072 has been marked as a duplicate of this bug. ***

Comment 3 Havoc Pennington 2000-01-24 17:11:59 UTC
This bug has just been fixed in the upstream CVS version of GNOME;
when the GNOME Project makes a release of the fixed version,
we will include it in Red Hat.

Comment 4 Preston Brown 2000-02-16 15:36:59 UTC
Havoc:

Will this make it for 6.2?

Comment 5 Havoc Pennington 2000-02-16 17:21:59 UTC
CVS version (stable branch) seems to have a number of fixes, including
this and the segfault-if-E-background-pixmap-no-longer-exists bug.
I think I'll just diff our tarball against the CVS version of the
terminal and apply the patch to the RPM. However the patch is somewhat large and
it makes me a bit nervous to use the unreleased code.

Comment 6 Havoc Pennington 2000-02-17 17:23:59 UTC
On second thought, it turns out that on Feb 1 we updated the Rawhide
RPM to the latest upstream version, and I can no longer reproduce this
bug.

Comment 7 andrew.pickin 2000-02-18 09:08:59 UTC
If gnome-core-1.0.55-7.i386.rpm is supposed to fix this bug, unfortunately I can
confirm that it DOES NOT.

-rwxr-xr-x   1 root     root        50800 Feb  9 00:58 /usr/bin/gnome-terminal

still puts a 'c' on the prompt on returning from vim.

Sorry

Comment 8 Havoc Pennington 2000-02-18 16:27:59 UTC
The bug is in gnome-LIBS not gnome-core. If upgrading the libraries
doesn't help then let me know.

Comment 9 andrew.pickin 2000-02-18 16:33:59 UTC
Yes fixed, agreed, it's gone away. Thanks.

Comment 10 andrew.pickin 2000-02-21 11:12:59 UTC
No. It's only fixed over remote login.

See:

[root@royals GNOME]# rpm -Uvh gnome-libs-1.0.55-9.i386.rpm
gnome-libs-devel-1.0.55-9.i386.rpm
package gnome-libs-1.0.55-9 is already installed
package gnome-libs-devel-1.0.55-9 is already installed
[root@royals GNOME]# vi
c[root@royals GNOME]#

Comment 11 Preston Brown 2000-02-24 02:01:59 UTC
havoc: this bug does persist. Not sure if it is going to get fixed or not...

Comment 12 Havoc Pennington 2000-02-29 19:51:59 UTC
ok, NOW it is supposed to be fixed with the latest gnome-libs.

Comment 13 andrew.pickin 2000-03-01 12:35:59 UTC
AMP: Sorry, still there!

[root@royals download]# rpm -Uvh gnome-libs-1.0.55-12.i386.rpm
package gnome-libs-1.0.55-12 is already installed
[root@royals download]# vi
c[root@royals download]# date
Wed Mar  1 12:44:26 GMT 2000


Note You need to log in before you can comment on or make changes to this bug.