Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7037 - wu-ftpd fails to bind to ftp-data
Summary: wu-ftpd fails to bind to ftp-data
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-16 06:32 UTC by gman
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-03 20:25:28 UTC


Attachments (Terms of Use)

Description gman 1999-11-16 06:32:57 UTC
wu-ftp-2.6.0-1 can't bind to the ftp-data port every now and then. Once it
starts complaining to about it, I have for goto single user mode then back
to run level 3 to get it working again..

The redhat box is multi-homed and has about 400+ IP aliases.. In
/etc/ftpaccess we only have 3 virtual ftp sites define.

Here is what messages is saying..
ftpd[12279]: <--- 425 Can't build data connection: Connection refused.

This has happen to use several times.. it doesn't start happening right
away.. After the first time this happen it took another 2 weeks before this
showed up again... Now its coming up every two or three days..


kernel is 2.2.5-20 currently, we also had 2.2.12 do the same to us...

I thought it might be inetd causing this problem. So I increased the number
of connectiosn per second allowed. Then ran a port scan on the C class we
use. This resulted in inetd just completely disabling ftp like it is
suppose to do.. Any ideas?? Thanks!...

Comment 1 gman 1999-11-19 02:02:59 UTC
I think I solved the problem.. I just increase the number of files I could open
at a time. from 4096 to 8192... I also increased the number of inodes that could
be opened...

Comment 2 Elliot Lee 2000-02-03 20:25:59 UTC
Reporter indicates problem is solved.


Note You need to log in before you can comment on or make changes to this bug.