Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7020 - sort doesn't work
Summary: sort doesn't work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: textutils
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
: 10117 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-15 17:43 UTC by Timur
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-22 17:18:20 UTC


Attachments (Terms of Use)

Description Timur 1999-11-15 17:43:16 UTC
sort doesn't work in binary mode properly.
Input:
ADa
aba
ADc
Output:
aba
ADa
ADc
Correct output:
ADa
ADc
aba
Just figure out, how many people uses sort in their scripts. In example,
vim+ctags doesn't work, cuz ctags uses sort as external sort program, and
vim by default doesn't understand unsorted tags files.

Comment 1 Bill Nottingham 1999-11-15 19:11:59 UTC
sort is paying attention to locales now. What's your locale setting?

Comment 2 Bernhard Rosenkraenzer 1999-11-22 17:18:59 UTC
It's not a bug, it's a feature - the new sort is POSIX compliant, therefore
some flags have changed. (See info sort)

Comment 3 Jeff Johnson 2000-03-11 18:00:59 UTC
*** Bug 10117 has been marked as a duplicate of this bug. ***

Comment 4 sidlon 2000-03-11 19:00:59 UTC
While this isn't a bug in sort, isn't it a problem with the RH6.1 distribution that the default installation doesn't set the LC_ALL variable to work with sort 2.0?  Considering how many people depend on the sort command, it shouldn't take additional tinkering to install RH and have a usable sort.


Note You need to log in before you can comment on or make changes to this bug.