Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7016 - problems with kppp and network connection
Summary: problems with kppp and network connection
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-15 16:08 UTC by jsberrios
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-19 21:40:35 UTC


Attachments (Terms of Use)

Description jsberrios 1999-11-15 16:08:10 UTC
I have a small network at home in which I use my Linux computer as a file
server and a printer server using SAMBA.  I also connect to the internet
with this machine using KPPP.  With Red Hat Linux 6.0 this worked well, but
with Red Hat Linux 6.1 once I get my modem connected I get the following
message:

Nov 14 18:50:47 gator pppd[1529]: Connect: ppp1 <-->/dev/cua0
Nov 14 18:50:48 gator pppd[1529]: Remote message: ^@
Nov 14 18:50:50 gator pppd[1529]: not replacing existing default route to
eth0 [10.8.11.2]
Nov 14 18:50:50 gator pppd[1529]: local  IP address 12.77.216.211
Nov 14 18:50:50 gator pppd[1529]: remote IP address 204.127.160.1

As soon as I saw this happening, I disconnected my network card.  As soon
as I did this and retried again, I was able to connect and surf the
internet.

Is there a way that I can keep my network card and network configuration
and at the same time be able to surf the net using the dial-up connection?

Thanks in advance for your help on this matter

Comment 1 Michael K. Johnson 1999-11-19 21:40:59 UTC
Remove the default route for your internal network. You should only need
one default route, and if your internal network does not provide a route
to the internet, you shouldn't have a default route for it.

In /etc/sysconfig/network, make sure you have
GATEWAY=
GATEWAYDEV=
and that should fix it.

Comment 2 Need Real Name 2002-11-21 02:27:22 UTC
Hello

I am new to Linux. Using RedHat 7.2.

I have the same setup as described in this post and am having the same problem.
I have a small home network with Samba, and a modem to dial into the Internet. I
can connect fine with kppp but can't see anything on the Internet (except for
the remote gateway).

I have tried your resolution but that doesn't seem to work either. I have
updated to the latest initscripts, ppp and pam packages using red hat network.

I have also tried adding GATEWAY= and GATEWAYDEV= to the /etc/sysconfig/network
file, with no success.

I have a gateway set up to another machine that also dials to the Internet, so
am able to browse the Internet via the network through that machine. However, I
would also like to be able to use the dial-up as well.

Here is the result of route -n before connecting using kppp:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0

and here is the result of route -n after connnecting using kppp:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
203.167.253.60  0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0

Hope you can help me.

thanks in advance
Faizal


Note You need to log in before you can comment on or make changes to this bug.