Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 70153 - vmware_drv is missing?
Summary: vmware_drv is missing?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86
Version: limbo
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
: 80308 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-30 19:54 UTC by Jason Gilbert
Modified: 2007-04-18 16:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-23 10:44:11 UTC


Attachments (Terms of Use)

Description Jason Gilbert 2002-07-30 19:54:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
the vmware_drv for XFree86 is missing.  It would be nice if you could install in
vmware w/o any problems.  Including setting up X in the installer.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install XFree86 package
2.Do a 'ls /usr/X11R6/lib/modules/drivers/'
3.Observe in the ls output that a vmware driver is not present.


Additional info:

Comment 1 Mike A. Harris 2002-07-31 00:46:00 UTC
The vmware_drv.o XFree86 driver is intentionally excluded from our
XFree86 packages.

While we hope that Red Hat Linux works with VMware, and vice versa,
we do not officially support systems which are running VMware, and
we also do not support installation of the distribution into
a VMware virtual machine, Virtual PC, User Mode Linux, or any other
emulated or simulated environment.

VMware inserts it's own kernel modules into the running kernel.
Red Hat does not support any system which is using kernel modules that
did not ship with the distribution or as an erratum update.  We simply
receive too many bug reports from users using such systems, and we
are unable to support such setups.

In the past, we did provide the vmware_drv.o driver at one point,
however we have received far too may bug reports, and user technical
support queries, etc. from people whom expected that if Red Hat
has shipped a driver then Red Hat had some obligation to support it.

Since we can not, and do not support it, it was decided to remove
the driver from the distribution.

You may obtain the vmware_drv.o driver from www.vmware.com or compile
it yourself from XFree86 source code.

If you encounter problems with the distribution under VMware, please
ensure that the bug/problem exists also under Red Hat Linux running
natively on a real processor without VMware being used and/or loaded
before reporting any software problems.

In closing, while we do not support vmware, and do not test the distro
with it, we do hope that the distribution works well nonetheless, and
when possible, we try to look into any reasonable bug report,
especially if it is obvious that a bug is generic enough that VMware
is not potentially a part of the problem.

There is currently no intention to include the XFree86 vmware driver
in the distribution.



Comment 2 Mike A. Harris 2002-12-27 01:59:59 UTC
*** Bug 80308 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.