Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7013 - Problems with zgv and PNG files - src and binary RPM
Summary: Problems with zgv and PNG files - src and binary RPM
Keywords:
Status: CLOSED DUPLICATE of bug 7012
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: zgv
Version: 6.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: drop
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-15 15:58 UTC by Henri J. Schlereth
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-15 16:43:30 UTC


Attachments (Terms of Use)

Description Henri J. Schlereth 1999-11-15 15:58:29 UTC
I have tried to use zgv with PNG on 4 RH6.0 systems and it errors out.
I have tried re-compiling from the src.rpm and it gives me a:

zgv.c: In function `makedirxv332':
zgv.c:1711: warning: suggest explicit braces to avoid ambiguous `else'
zgv.c: In function `update_xvpics':
zgv.c:1842: `errno' undeclared (first use in this function)
zgv.c:1842: (Each undeclared identifier is reported only once
zgv.c:1842: for each function it appears in.)
zgv.c:1842: `EEXIST' undeclared (first use in this function)
zgv.c:1842: `EACCES' undeclared (first use in this function)
zgv.c:1921: warning: suggest explicit braces to avoid ambiguous `else'
make: *** [zgv.o] Error 1

And I have patched the the code with the patches that came with the src
RPM. (zgv-3.0-8). I have downloaded the 3.3 tarball and modified it
and compiled it successfully. It does give lots of explict braces warnings
but still compiles. And of course works. I understand that 3.5 will be out
in a few weeks as well. I just thought you might like to know.

The binary rpm seems to default for no PNG support and if you are working
for a GIF free environment that can be a real pain.

Comment 1 Henri J. Schlereth 1999-11-15 16:00:59 UTC
This is a duplicate of 7012 please ignore.

Comment 2 Bill Nottingham 1999-11-15 16:43:59 UTC
*** This bug has been marked as a duplicate of 7012 ***


Note You need to log in before you can comment on or make changes to this bug.