Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 69943 - mc's config files should be in /etc/mc, not /usr/lib/mc/
Summary: mc's config files should be in /etc/mc, not /usr/lib/mc/
Keywords:
Status: CLOSED DUPLICATE of bug 2188
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-26 17:32 UTC by Marc MERLIN
Modified: 2015-01-07 23:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:49:18 UTC


Attachments (Terms of Use)

Description Marc MERLIN 2002-07-26 17:32:18 UTC
To be FHS compliant, you should either symlink the following files to /etc/mc,
or compile mc to look for them there:

/usr/lib/mc/mc.ext
/usr/lib/mc/mc.ini (not supplied by default, but looked up by mc)
/usr/lib/mc/mc.lib
/usr/lib/mc/mc.menu

Comment 1 Havoc Pennington 2002-07-27 16:24:50 UTC
I'd prefer to see this patch upstream than in RH.

Comment 2 Marc MERLIN 2002-07-28 01:00:28 UTC
I looked at the source, and what debian did.
It's apparently just a compile option issue:

debian's diff has:
+diff -ruN mc-4.5.55.orig/Make.common.in mc-4.5.55/Make.common.in
+--- mc-4.5.55.orig/Make.common.in      Fri Jul 20 17:22:50 2001
++++ mc-4.5.55/Make.common.in   Sun Aug 26 18:10:57 2001
+@@ -15,7 +15,7 @@
+ mandir     = @mandir@
+ mclibdir   = $(libdir)/mc
+ suppbindir = $(mclibdir)/bin
+-confdir    = $(sysconfdir)
++confdir    = /etc/mc
+ localedir  = $(datadir)/locale
+ man1dir    = $(mandir)/man1
+ manext     = 1

Comment 3 Jindrich Novy 2004-10-30 09:14:33 UTC

*** This bug has been marked as a duplicate of 2188 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:49:18 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.