Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6985 - Linuxconf not accepting root partition after compiling new kernel
Summary: Linuxconf not accepting root partition after compiling new kernel
Keywords:
Status: CLOSED DUPLICATE of bug 5737
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-13 05:51 UTC by Keith E. McComb
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-19 21:36:18 UTC


Attachments (Terms of Use)

Description Keith E. McComb 1999-11-13 05:51:51 UTC
I have kernel 2.2.12-20 running on two machines - a HP 7280 Pavilion, and a
separate one built using a Celeron 450 MHz and a Maxtor 20G drive.  On both
machines, after compiling a kernel specific for the machine, whenusing
linuxconf to set it up as bootable, it informs me that either the partition
is bad or is not a valid ext2 partition.  It works just fine if I manually
edit /etc/lilo.conf then run /sbin/lilo.  I have only recently upgraded
from the RedHat 6.0 to the 6.1 package.  linuxconf worked fine when I was
using the 6.0 kernel.  (I believe the kernel was 2.2.5-15.)

Comment 1 martin 1999-11-15 20:27:59 UTC
The same happended to me (Toshiba 4000CDT Laptop, ran under RH 5.2 with
self-compiled 2.2.13-Kernel before). After RH install had destroyed my
lilo.conf, I couldnt4t enter the exisiting 2.2.13 Kernel into lilo.conf anymore

Comment 2 martin 1999-11-15 20:30:59 UTC
The same happended to me (Toshiba 4000CDT Laptop, ran under RH 5.2 with
self-compiled 2.2.13-Kernel before). After RH install had destroyed my
lilo.conf, I couldnt4t enter the exisiting 2.2.13 Kernel into lilo.conf anymore
with linuxconf, as /dev/hda5 was, according to linuxconf, an invalid partition.
(Nor could I set /dev/hda5 as default root partition for lilo). Hand editing
worked fine.
(sorry I submitted my last incomplete comment - Bugzilla newbie. please delete!
Martin Wilck, Inst. for Tropospheric Research, Leipzig, Germany

Comment 3 martin 1999-11-16 20:04:59 UTC
Just the same on a networked workstation with SCSI disks - linuxconf doesn4t
accept /dev/sda5 as root partition any more.

Comment 4 martin 1999-11-16 20:06:59 UTC
Just discovered that this seems to be the same bug as 5737.

Comment 5 Michael K. Johnson 1999-11-19 21:36:59 UTC
*** This bug has been marked as a duplicate of 5737 ***


Note You need to log in before you can comment on or make changes to this bug.