Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6982 - ppp demand mode does not work
Summary: ppp demand mode does not work
Keywords:
Status: CLOSED DUPLICATE of bug 6981
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-13 03:51 UTC by csgordon
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-17 15:06:47 UTC


Attachments (Terms of Use)

Description csgordon 1999-11-13 03:51:36 UTC
when starting pppd with the demand option, it will d demand dailing once.
After that call hangs up, it will NOT call again.  I am using the same
scripts to run pppd in demand mode as I did in RH5.2 (had to recompile pppd
under 5.2).  I am starting ppp from my own scripts vice setting it in the
/etc/sysconfig files.  Of other note, restarting the networking with
/etc/rc.d/init.d/network restart causes pppd, if running, to dial even if
there is no traffic bound for that interface.  The ../netwrork restart
never touches the ppp0 interface (doesn't see it in the $interfaces_boot
variable).

Comment 1 csgordon 1999-11-15 22:02:59 UTC
I have updated to ppp-2.3.10-3.  I can now cause ppp to demand dial from the box
running pppd, but no other system can force a connection to be made.  Once pppd
has connected, then all systems can route traffic over the interfaces.  Stoping
and staring pppd now works properly.  The following are the pertinent
files/commands:

--------/etc/ppp/options--------------
# /etc/ppp/options
demand				# Set dial on demand
ktune
idle 600			# Disconnet when idle for 600 seconds
ipcp-accept-remote		# Set remote IP address
ipcp-accept-local               # Get IP from remote
lock				# Lock modem
debug                           # Log debug info
modem 115200 crtscts             # Use modem control lines
defaultroute                    # Make PPP setup defaule route
name csgordon
connect '/usr/sbin/chat -v -f /etc/ppp/visi.chat'

-------/etc/ppp/visi.chat-----------------
ABORT 'BUSY'
ABORT 'ERROR'
ABORT 'NO CARRIER'
ABORT 'NO DIALTONE'
REPORT CARRIER
REPORT CONNECT
""
AT&F1
OK ATDT8779538
CONNECT

---------command used to start pppd------------
/usr/sbin/pppd /dev/modem 57600 :204.71.248.1

NOTE:  My ISP uses PAP for authentication.  A chat script that connects via a
terminal log in will NOT work.  My pap-secrets file is set and functions
properly.

The output to syslog reveals nothing special (even with kdebug 1 set), but is
attached for informational purposes.

Nov 15 17:54:32 localhost modprobe: can't locate module char-major-108
Nov 15 17:54:32 localhost pppd[1349]: pppd 2.3.10 started by root, uid 0
Nov 15 17:54:32 localhost pppd[1349]: Using interface ppp0
Nov 15 17:54:32 localhost pppd[1349]: local  IP address 10.64.64.64
Nov 15 17:54:32 localhost pppd[1349]: remote IP address 204.71.248.1
Nov 15 17:54:53 localhost pppd[1349]: Starting link
Nov 15 17:54:54 localhost chat[1351]: abort on (BUSY)
Nov 15 17:54:54 localhost chat[1351]: abort on (ERROR)
Nov 15 17:54:54 localhost chat[1351]: abort on (NO CARRIER)
Nov 15 17:54:54 localhost chat[1351]: abort on (NO DIALTONE)
Nov 15 17:54:54 localhost chat[1351]: report (CARRIER)
Nov 15 17:54:54 localhost chat[1351]: report (CONNECT)
Nov 15 17:54:54 localhost chat[1351]: send (AT&F1^M)
Nov 15 17:54:54 localhost chat[1351]: expect (OK)
Nov 15 17:54:54 localhost chat[1351]: AT&F1^M^M
Nov 15 17:54:54 localhost chat[1351]: OK
Nov 15 17:54:54 localhost chat[1351]:  -- got it
Nov 15 17:54:54 localhost chat[1351]: send (ATDT8779538^M)
Nov 15 17:54:54 localhost chat[1351]: expect (CONNECT)
Nov 15 17:54:54 localhost chat[1351]: ^M
Nov 15 17:55:19 localhost chat[1351]: ATDT8779538^M^M
Nov 15 17:55:19 localhost chat[1351]: CONNECT
Nov 15 17:55:19 localhost chat[1351]:  -- got it
Nov 15 17:55:19 localhost pppd[1349]: Serial connection established.
Nov 15 17:55:19 localhost pppd[1349]: Connect: ppp0 <--> /dev/modem
Nov 15 17:55:24 localhost pppd[1349]: Local IP address changed to 209.8.198.35
Nov 15 17:55:24 localhost pppd[1349]: Remote IP address changed to
206.246.195.71

Comment 2 Michael K. Johnson 1999-11-17 15:06:59 UTC
*** This bug has been marked as a duplicate of 6981 ***


Note You need to log in before you can comment on or make changes to this bug.