Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 69748 - Unhandled Exception -- fsset.py, in badblocksDevice
Summary: Unhandled Exception -- fsset.py, in badblocksDevice
Keywords:
Status: CLOSED DUPLICATE of bug 66181
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-24 22:32 UTC by facility
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-07-24 22:33:07 UTC


Attachments (Terms of Use)
Crash dump from Anaconda (deleted)
2002-07-24 22:33 UTC, facility
no flags Details

Description facility 2002-07-24 22:32:06 UTC
When formatting with bad block check, installer crashes with debug info near the
very end of the format of the last partition.  First 2 non-swap partitions
format fine.


Version-Release number of selected component (if applicable):
Redhat 7.3 Anaconda.  Whatever was on the CDROM.  I don't know
where the version number is listed.

How Reproducible: Every time

1.Buy Wal-Mart computer. :)
2.Partitiion into 32M/512M/4G/25G
3.Format all partitions (ext3) checking for bad blocks

Actual Results:

Installer crashes with debug info near the very end of the format of the last
partition.  First 2 non-swap partitions format fine.
End of traceback looks like this.

  File "/usr/lib/anaconda/fsset.py", line 210, in badblocksDevice
    l = string.split(num, '/')
TypeError: argument 1: expected read-only character buffer, int found


Expected Results:

All partitions format with bad block check; and installer continues.


NOTE: attachment of Full crash dump will follow.

Additional Information:

Comment 1 facility 2002-07-24 22:33:02 UTC
Created attachment 66904 [details]
Crash dump from Anaconda

Comment 2 Michael Fulbright 2002-08-02 18:52:12 UTC
Bad blocks were detected and the installer crashed handling the exception.
You'll have to consider if you want to use the drive considering it failed the test.

*** This bug has been marked as a duplicate of 66181 ***


Note You need to log in before you can comment on or make changes to this bug.