Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6965 - gdm duplicates path on login
Summary: gdm duplicates path on login
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-13 00:41 UTC by Nadeem
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-17 22:04:37 UTC


Attachments (Terms of Use)

Description Nadeem 1999-11-13 00:41:32 UTC
Hi,

gdm appears to duplicate the path when a user logs in, e.g.

PATH=$PATH:$PATH

I've tested this with several windowmanagers executed from gdm, and all
seem to display the problem.  Starting X and said windowmanagers from the
command line with xinit doesn't display the problem, thus I think it exists
somehwere in gdm. grep through GDM's config tree, I couldn't find anything
that would seem to duplicate the path, so I'm guessing its something in the
code.

Comment 1 Elliot Lee 1999-11-17 22:04:59 UTC
Can't reproduce here. The PATH does seem to get a couple of duplicate entries,
but the whole path is definitely not doubled, and the duplication is merely a
cosmetic defect. This may just be the system-wide or user profile doing its
usual.


Note You need to log in before you can comment on or make changes to this bug.