Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6951 - a.out binaries fail with segmentation fault upon invocation
Summary: a.out binaries fail with segmentation fault upon invocation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL: www.rx30.com
Whiteboard:
: 7075 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-12 13:33 UTC by dschmidt
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-11-09 19:09:50 UTC


Attachments (Terms of Use)

Description dschmidt 1999-11-12 13:33:38 UTC
a.out binaries that ran fine on RH 5.2 and 6.0 fail immediatly with
Segmentation Fault on RH 6.1. I suspect that the problem is with the iBCS
emulator. These a.out binaries are producted on a SCO development platform.

Comment 1 Cristian Gafton 2000-01-04 22:27:59 UTC
Assigned to dledford

Comment 2 Bill Nottingham 2000-02-06 05:41:59 UTC
*** Bug 7075 has been marked as a duplicate of this bug. ***

Comment 3 Brent R Brian 2000-09-20 16:14:28 UTC
The problem can be fixed by placing the SCO BINARY on a device that is formated 
with 512 byte sectors (ms-dos mount works fine).

In the upgrade from 5.2 -> 6.1 the disk was not reformatted, in the fresh 
install of 6.1 it was.



Comment 4 dschmidt 2000-11-09 19:09:47 UTC
The suggested fix posted on 09-20-2000 does not work. RH 6.1 was loaded as a 
fresh install. Bug still exists in RH 6.2.

Comment 5 Ben LaHaise 2002-06-03 22:16:57 UTC
Does this happen with the 2.4 kernel included with RHL 7.3?  Please reopen the
bug if so.


Note You need to log in before you can comment on or make changes to this bug.