Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 694 - system init ignores /forcefsck
Summary: system init ignores /forcefsck
Keywords:
Status: CLOSED DUPLICATE of bug 11
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: SysVinit
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-05 19:51 UTC by magill
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-05 20:14:43 UTC


Attachments (Terms of Use)

Description magill 1999-01-05 19:51:15 UTC
'shutdown -F' touches /forcefsck in order to force an fsck
of all filesystems on reboot.  The init scripts should
notice this file and execute the fsck -- they do not.  It is
currently impossible to force an fsck of all filesystems at
boot time.  This functionality is insensive to the
filesystem type.  This functionality worked on a previous
version of
RedHat.

There is a reference to a /fsckoptions file in the init
scripts, but this file is almost useless as it passes its
options to all filesystems which is generally not
appropriate.

Comment 1 Bill Nottingham 1999-01-05 20:14:59 UTC
*** This bug has been marked as a duplicate of 11 ***


Note You need to log in before you can comment on or make changes to this bug.