Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6936 - 'more /proc/misc' segfaults
Summary: 'more /proc/misc' segfaults
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-11 21:07 UTC by Kjartan Maraas
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-27 03:08:20 UTC


Attachments (Terms of Use)

Description Kjartan Maraas 1999-11-11 21:07:29 UTC
Not much more to say:

[kmaraas@km-lt kmaraas]$ rpm -qf /bin/more
util-linux-2.9w-24
[kmaraas@km-lt kmaraas]$ more /proc/misc
Segmentation fault (core dumped)
[kmaraas@km-lt kmaraas]$

Comment 1 Stephen J. Friedl 2000-02-27 03:08:59 UTC
This is not a bug in more: it's a bug in /proc/misc(!) When doing a low-level
read(2) on /proc/misc, asking for a small number of bytes (say, 2) returns
the full size of what /proc/misc has to offer even if this overflows the
caller's buffer. More allocates a two-byte buffer on the stack, and the
stack gets trashed when the read(2) call returns 26 instead of two.

Not sure if I will be able to track down the kernel problem, but at least
don't waste your time looking at more(1).


Note You need to log in before you can comment on or make changes to this bug.