Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6929 - -X option broken in this release of tar
Summary: -X option broken in this release of tar
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tar
Version: 6.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-11 15:30 UTC by ehm
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-11 15:38:22 UTC


Attachments (Terms of Use)

Description ehm 1999-11-11 15:30:29 UTC
The -X option is broken in this release of tar.
It works in version tar-1.12-9 (RH 6.0), but is
broken in tar-1.13.11-1 (RH6.1).

Comment 1 Bernhard Rosenkraenzer 1999-11-11 15:38:59 UTC
I've just tried reproducing this. The -X option works for me

touch rubbish0 rubbish1
echo "rubbish1" >exclude.list
tar cf rubbish.tar r* -X exclude.list

doesn't include the rubbish1 file.

If there's anything else wrong with -X, please be a bit more specific
about what the problem is.
Also, you might want to try the tar version in rawhide (1.13.14-1).


Note You need to log in before you can comment on or make changes to this bug.