Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6928 - Text install does not use keyboard layout
Summary: Text install does not use keyboard layout
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-11 15:28 UTC by udippel
Modified: 2015-01-07 23:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-29 20:29:29 UTC


Attachments (Terms of Use)

Description udippel 1999-11-11 15:28:50 UTC
Installing RH6.1 with graphical interface, my selection of
keyboard layout (german) is accepted (test area), used
throughout the installation and implemented.
During text installation, whatever I enter, the keyboard
layout is US. Even after reboot, the keyboard is invariably
US. In RH6.0 this worked fine, also in text install.

Comment 1 udippel 1999-11-16 15:47:59 UTC
To add some precision and examples to the report(s) since we use a mixture of
RH6.0 and RH6.1 and a mixture of german and swiss-german keyboards:
Text install RH6.1: keyboard layout entered as 'german'. Consequently, mount
point '/' would require shift+7. But shift+7 brings up the '&' (US
layout). Entering any 'y' in root password (invisible) later - after reboot -
requires 'z' (and vice versa). In the terminal/shell v,d and | appear as '[' and
similar (I hope those appear on your screen in this mail - I talk about the
german 'Umlaute'!). In X everything seems to be okay as far as I have seen.
The situation is very much different with the swiss-german keyboard. Though
entered correctly during install (and displayed in linuxconf) in terminal and X
I find US throughout.
I am really sorry if I confused the behaviour under RH6.0 and 6.1 w.r.t. german
and swiss-german keyboard and(!) text and graphic installer. In any case: we
don't use a single US keyboard but English throughout without exceptions. This
just comes to my mind: maybe it has to do with passing of german keyboard
parameters correctly (only) when german is selected as language?
Only in case you want to give a fast try:
german keyboard:       shift+3 -> ' (paragraph)
swiss-german keyboard: shift+3 -> * (asterix)
us keyboard:           shift+3 -> # (hash)
Just ask if more details are required!

Comment 2 Jay Turner 1999-11-29 20:29:59 UTC
*** This bug has been marked as a duplicate of 7275 ***


Note You need to log in before you can comment on or make changes to this bug.