Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6927 - Xircom CE3B-100 fails to work for 10BaseT
Summary: Xircom CE3B-100 fails to work for 10BaseT
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-11 15:11 UTC by Kevin L. Mitchell
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-06 05:33:20 UTC


Attachments (Terms of Use)

Description Kevin L. Mitchell 1999-11-11 15:11:06 UTC
(Consider this an FYI on how I fixed this problem)

The Linux PCMCIA package has a driver, named xirc2ps_cs, for
many Xircom cards.  There is, however a (known) problem in
that it may not work properly work with autosensing cards--
for instance, my Xircom CE3B-100 works correctly in 100BaseT
mode, but not 10BaseT mode.

While trying to find out more about what the problem is, I
visited the Linux PCMCIA web page, and discovered a forum
where someone had asked a question concerning a problem very
similiar to mine; this person was told about a development
release, dated November 4th, 1999 (I think of 3.1.4), that
seemed to correct the issue.

Rather than install the development snapshot, I grabbed it
and back-ported the logic changes to clients/xirc2ps_cs.c
and rebuild the kernel RPM.  This seems to have solved my
problem.  I'll submit the patch I generated shortly...

Comment 1 Cristian Gafton 2000-01-04 22:26:59 UTC
Assigned to dledford

Comment 2 Bill Nottingham 2000-02-06 05:33:59 UTC
PCMCIA-3.1.4 is in the current Raw Hide kernel builds.


Note You need to log in before you can comment on or make changes to this bug.