Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6908 - Deleting old GTK shared libraries unacceptable
Summary: Deleting old GTK shared libraries unacceptable
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-11 03:01 UTC by whitis
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-11 15:34:23 UTC


Attachments (Terms of Use)

Description whitis 1999-11-11 03:01:33 UTC
Under the current system, installing gnome from RPMs is
hazardous to your health.  You won't get more than one
GNOME app to work at a time (unless they came in the
same bundle).

This bug report applies to all versions of GTK rpms - even
the old rpms need to be fixed (or a new rpm full of old
versions created).

Redhat loves to delete old versions you still need.  One
place this hurts you is
GTK shared libraries.  The shared library system is smart
enough to
handle multiple library versions simultaneously installed
and will
try to pick the closest match;  Redhat screws this up by
deleting
the old ones.  This
is why you can almost never get gnome apps to work.  Every
gnome app
typically needs a different library version (and they aren't
compatible with
other versions because the library calling conventions
haven't
stabilized, which would be fine if redhat didn't delete the
old ones).
Every time you install a new gnome app, you need to upgrade
one or
more libaries, which thanks to redhat will break all your
other
gnome apps.

Comment 1 Michael Fulbright 1999-11-11 15:34:59 UTC
This is not a gnome-libs issue.

Installing the gtk+-1.2-xxx packages will not break existing
applications which are linked against gtk+-1.0. The gtk+10 package,
which is required in order to install the gtk+-1.2 package, has the
required shared libraries which gtk+-1.0 apps require.  The
upgrade to gtk+-1.2 unless the gtk+-1.0 package exists, or you
used --force to install, in which case the consequences are not
guaranteed to be good.


Note You need to log in before you can comment on or make changes to this bug.