Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6906 - PCMCIA network Card cant transmit
Summary: PCMCIA network Card cant transmit
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL: http://www.linksys.com/support/soluti...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-11 02:02 UTC by jbore
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-22 15:58:16 UTC


Attachments (Terms of Use)

Description jbore 1999-11-11 02:02:00 UTC
After entering the IP address and such for the local
machine for NFS install, the network card never seems to
transmit.

Sony VAIO PCG-N505VE, LinkSys 10/100 EtherFast Card,
(PCMPC100)

From the log...
cardmgr[14] socket 0: Linsys EtherFast 10/100 Fast Ethernet
cardmgr[14] executing 'modprobe net/8390.o'
cardmgr executing 'modprobe pcnet_cs.o'
eth0:  NE2000 Compatible io 0x300, irq 5, hw_addr xxxxxx...
cardmgr[14] fopen(stabfile) failed:  no such file or
directory)
cardmgr[14] exiting

and then while it is trying to use the network i get these

eth0: tx timed out, lost interrupt? TSR=0x43, ISR=0x1,
t=1000
eth0: tx timed out, lost interrupt? TSR=0x43, ISR=0x1,
t=1500

etc...

help...




It wont respond to pings either

Comment 1 jbore 1999-11-11 05:10:59 UTC
http://www.linksys.com/support/solution/nos/linux_others.htm

mentions a new rev of the chip set and has links for the kernel
driver...  how does one get these changes in the pcmcia boot floppy?

Comment 2 Jay Turner 1999-11-29 20:38:59 UTC
This issue has been forwarded to a developer for further action.

Comment 3 brandon 1999-12-24 20:48:59 UTC
I have this same problem on my PCG-N505VE.  I believe the issue is that the
sound subsystem is using IRQ 5.  There needs to be a way to choose a different
IRQ or something during probe.  You cannot use any method of installation on
this laptop that requires a second disk either as the fd is USB and only works
for the first disk boot :(  Someone help me out here, I'm dying to run RH on my
shiny new laptop.

Comment 4 brandon 1999-12-28 01:04:59 UTC
This can be solved by doing the following

Get the latest pcmcia.img for RedHat
Mount it as type msdos somewhere (loopback device)
Copy the initrd.img file to somewhere else
Gunzip this initrd.img and mount the result somewhere (type ext2, loop)
Go into your mounted initrd tree and edit '/etc/pcmcia/config.opts'
Add 'exclude irq 5'
Unmount the initrd image
gzip -9 the initrd image
copy it back to the mounted pcmcia.img tree overwriting the old initrd.img
unmount the pcmcia.img
rewrite your install floppy with your modified pcmcia.img and boot
install and enjoy


Note You need to log in before you can comment on or make changes to this bug.