Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 68914 - "mpage -2H xxx.ps | lpr" doesn't go landscape
Summary: "mpage -2H xxx.ps | lpr" doesn't go landscape
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cups
Version: 8.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 76419 76427 76857 78721 78746 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-15 21:57 UTC by Horst H. von Brand
Modified: 2008-05-01 15:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-22 10:39:34 UTC


Attachments (Terms of Use)

Description Horst H. von Brand 2002-07-15 21:57:58 UTC
Description of Problem:
Printing side-by-side using mpage -2H prints the 2 pages in portrait, not landscape.
cups enabled, printer is a HP Laserjet 4000 connected to the network.
ghostscript shows the file fine

Version-Release number of selected component (if applicable):


How Reproducible:
Always

Steps to Reproduce:
1. mpage -2H xxx.ps > xxx-2.ps
2. lpr xxx-2.ps
3. 

Actual Results:
Pages are printed in portrait (doesn fit paper, obviously), not landscape

Expected Results:
Landscape printing.


Additional Information:

Comment 1 Tim Waugh 2002-10-07 11:48:22 UTC
I've seen this too.

Comment 2 Carlos Rodrigues 2002-10-11 23:06:30 UTC
I'm seeing this with RedHat 8.0 also. Every landscape postscript file I throw at
cups gets printed in portrait. My printer is an Epson Stylus Color 880
CUPS+gimp-print driver.

Comment 3 H.Breimer 2002-10-12 12:48:56 UTC
Just installed box 8.0. Same problem. Workaround?


Comment 4 Carlos Rodrigues 2002-10-18 20:02:55 UTC
I've tried everytinh I remember (with all the available printer drivers etc.) to
no avail. This is really bad...

Comment 5 Carlos Rodrigues 2002-10-19 14:51:00 UTC
Picked up the cups SRPM from cd5 and replaced the 1.1.15 tarball with 1.1.16 and
it is working now (can print landscape again).

Comment 6 Tim Waugh 2002-10-21 15:57:58 UTC
*** Bug 76419 has been marked as a duplicate of this bug. ***

Comment 7 Tim Waugh 2002-10-22 08:25:43 UTC
*** Bug 76427 has been marked as a duplicate of this bug. ***

Comment 8 André Johansen 2002-10-23 07:19:54 UTC
I have a box upgraded from Red Hat 7.3/CUPS, and I see the same problem; it 
was able to print landscape before the upgrade, but not afterwards. 
 
I'll try the upgrade to 1.1.16. 


Comment 9 Tim Waugh 2002-10-23 08:28:57 UTC
You probably want to wait for 1.1.17, due out any day now.

Comment 10 giulioo 2002-10-30 09:33:44 UTC
*** Bug 76857 has been marked as a duplicate of this bug. ***

Comment 11 Lars Munch 2002-11-07 08:14:44 UTC
A fix for this bug can be found here:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=155534
I have applied this to the cups source rpm, and I got landscape printing again.

I have uploaded some RPMs on http://lwb1.it.dtu.dk/~lmc/rpms/ for those who can
wait for redhat 8.1 :-)


Comment 12 Tim Waugh 2002-11-28 11:07:36 UTC
*** Bug 78721 has been marked as a duplicate of this bug. ***

Comment 13 Tim Waugh 2002-11-28 17:55:42 UTC
*** Bug 78746 has been marked as a duplicate of this bug. ***

Comment 14 Need Real Name 2002-12-04 20:18:10 UTC
Grabbing cups-1.1.16-1.i386.rpm from the RawHide 1.0 distribution on rpmfind.net
fixed it for me.

Comment 15 Jos Vos 2002-12-05 16:34:06 UTC
Will an errata package be release for RH 8.0?  It is a pretty serious problem in
some office environments...

Comment 16 Tim Waugh 2002-12-05 16:36:01 UTC
I'd like to wait for at least 1.1.17 before issuing any advisory.  I'll keep
this open as a reminder.

Comment 17 André Johansen 2003-01-22 10:32:49 UTC
This seems to have been fixed with the recent cups-1.1.17-0.2 release; 
I'm able to print in landscape mode through KDE now. 
 


Note You need to log in before you can comment on or make changes to this bug.