Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 688 - rpm vfs does not list files
Summary: rpm vfs does not list files
Keywords:
Status: CLOSED DUPLICATE of bug 13
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-05 06:59 UTC by borgia
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-05 15:52:04 UTC


Attachments (Terms of Use)

Description borgia 1999-01-05 06:59:31 UTC
all you get when you enter an rpm package with mc's vfs is
the header list.
apply this patch to fix:
-cut-cut-
--- rpm.orig	Wed Dec 30 23:58:00 1998
+++ rpm	Fri
Jan  1 12:46:34 1999
@@ -5,6 +5,7 @@
 #            Tomasz
K&oczko (kloczek@rudy.mif.pg.gda.pl) 1997
 # minor changes
by Wojtek Pilorz (wpilorz@bdk.lublin.pl) 1997
 # minor
changes by Michele Marziani (marziani@fe.infn.it) 1997
+#
fix to handle new rpm output by Andrea Borgia
<borgia@students.cs.unibo.it> (1999)
 # (C) 1996 The Free
Software Foundation.
 #
 #
@@ -97,7 +98,7 @@
         echo
"$FILEPREF 0 $DATE INFO/CHANGELOG"
     fi

-    rpm -qlvp
$1 | sed -e 's/^\(..........\)[-t] /\1 1 /'
+    rpm -qlvp
$1 | sed -e 's/^\(..........\) /\1 1 /'
 }


mcrpmfs_copyout ()
-cut-cut-

Comment 1 Jeff Johnson 1999-01-05 15:52:59 UTC
*** This bug has been marked as a duplicate of 13 ***


Note You need to log in before you can comment on or make changes to this bug.