Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6877 - rftp has several bugs in it.
Summary: rftp has several bugs in it.
Keywords:
Status: CLOSED DUPLICATE of bug 7869
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcltk
Version: 6.1
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-10 14:23 UTC by jdlee
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 20:46:50 UTC


Attachments (Terms of Use)

Description jdlee 1999-11-10 14:23:03 UTC
The expect script rftp that comes with redhat has a couple
bugs.  Here are the fixes (and I've only tried to get
recursively, not put, so I'm not sure that that's bug free):

On line 312, append a " to the end of the line.

Insert this line between lines 205 & 206:
	if {$name=="." || $name==".."} return

Once these changes have been made, the script will actually
run (the first error is a parse error, so it doesn't run at
all).

rftp has been broken in at least 6.0 and 6.1, I've found the
bug both places.

Comment 1 Bill Nottingham 2000-02-05 20:46:59 UTC
*** This bug has been marked as a duplicate of 7869 ***


Note You need to log in before you can comment on or make changes to this bug.