Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6867 - rxvt incorrectly(?) sets DISPLAY variable
Summary: rxvt incorrectly(?) sets DISPLAY variable
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rxvt
Version: 6.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-10 00:49 UTC by grtllama
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-14 02:48:40 UTC


Attachments (Terms of Use)

Description grtllama 1999-11-10 00:49:50 UTC
I'm not sure if this is a bug or just an annoyance, but at
any rate...
rxvt sets the DISPLAY environment variable to unix:0.0
rather than just the local :0.0
It does this when no -display option is given to it.
I was using rxvt-2.6.1-1 from RedHat 6.1, and the same
problem seems to be present in rxvt-2.6.1-2 from Raw Hide.
Again, this may be some sort of intended behavior that just
seems odd to me, but I thought you should probably be
informed.

Thanks in advance,
Matt

Comment 1 Preston Brown 2000-01-14 02:48:59 UTC
unix:0.0 is a synonym for :0.0.  Trust us.

Comment 2 arr 2000-02-25 18:43:59 UTC
It *is* a bug, in particular the behaviour is inconsistent with the man page.
Note that if DISPLAY is set to :0.1 when rxvt is invoked, the rxvt window
still appears on Screen 0; to get reasonable behaviour, you need to use
rxvt -d $DISPLAY

Comment 3 grtllama 2000-03-01 13:35:59 UTC
The annoyance I found, although I was incorrect to blame rxvt, *is* still in
existance.  I suppose I could/should start a new bug, but if someone at redhat
is watching this...
Some (GTK) applications have trouble with the unix:0.0 DISPLAY variable.  I get
"can't resolve hostname unix!"  from a lot of GTK apps.  The workaround was to
undefine the compile-time option from rxvt (or just use -d, or ...) and I
assumed it was just an rxvt problem.
Next time I have an opportunity to reproduce this I'll send specifics.


Note You need to log in before you can comment on or make changes to this bug.