Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6825 - ifup-aliases script failure
Summary: ifup-aliases script failure
Keywords:
Status: CLOSED DUPLICATE of bug 5784
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netcfg
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-08 17:34 UTC by byrum
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-08 18:51:30 UTC


Attachments (Terms of Use)

Description byrum 1999-11-08 17:34:52 UTC
I noticed your name in the new 6.1 ifup-aliases script.  I
had problems bring up virtual interfaces and with a little
bugging noticed that the following line seemed to be
missing.

	DEVICE="`echo $FILE | sed -e 's/ifcfg\-//'`"

I placed this line in the function new_interface().  Just
below the assignment line that starts with IPGLOP and above
line that starts wtih DEVNUM.  Around line 133 in the file.

I am not sure if this is where you intended the assignment
to be made, but it seems to work correctly.

I added the line because at line 156 with the compare of

      if [ -z "$DEVICE" -o -z "$IPADDR" ]; then
      	echo "error in $FILE: didn't specify device or
ipaddr" >&2 ; exit 0
      fi

$DEVICE is empty and causes script to fail.

Comment 1 byrum 1999-11-08 17:40:59 UTC
Sorry about the strange context, I send this also in an email to Bill
Nottingham who is in the header of the file as the last person to
modify ifup-aliases.

Comment 2 Bill Nottingham 1999-11-08 18:51:59 UTC
*** This bug has been marked as a duplicate of 5784 ***


Note You need to log in before you can comment on or make changes to this bug.