Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 682355 (amigo) - Review Request: amigo - Translate spanish-english
Summary: Review Request: amigo - Translate spanish-english
Keywords:
Status: CLOSED NOTABUG
Alias: amigo
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE-DEADREVIEW
TreeView+ depends on / blocked
 
Reported: 2011-03-04 22:07 UTC by Yader Velásquez
Modified: 2012-09-11 17:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-11 17:49:32 UTC


Attachments (Terms of Use)

Description Yader Velásquez 2011-03-04 22:07:03 UTC
Spec URL: http://yaderv.fedorapeople.org/rpm/amigo/amigo.spec       
SRPM URL: http://yaderv.fedorapeople.org/rpm/amigo/amigo-1.0-6.fc14.src.rpm 

Description: 
Amigo is a translate application, it instantly defines 
and explains any Spanish-language word that you select 
with your mouse.

Comment 1 Sergio Belkin 2011-03-06 05:39:10 UTC
Hi Yader:

Some quick notes:

- Take a look at rpmlint output:
amigo.spec:6: W: non-standard-group System/Language
The value of the Group tag in the package is not valid.  Valid groups are:
"Amusements/Games", "Amusements/Graphics", "Applications/Archiving",
"Applications/Communications", "Applications/Databases",
"Applications/Editors", "Applications/Emulators", "Applications/Engineering",
"Applications/File", "Applications/Internet", "Applications/Multimedia",
"Applications/Productivity", "Applications/Publishing", "Applications/System",
"Applications/Text", "Development/Debug", "Development/Debuggers",
"Development/Languages", "Development/Libraries", "Development/System",
"Development/Tools", "Documentation", "System Environment/Base", "System
Environment/Daemons", "System Environment/Kernel", "System
Environment/Libraries", "System Environment/Shells", "User
Interface/Desktops", "User Interface/X", "User Interface/X Hardware Support".

amigo.spec: I: checking-url http://info.openanswers.org/downloads/amigo-lastest.tar.gz (timeout 10 seconds)
amigo.spec: W: invalid-url Source0: http://info.openanswers.org/downloads/amigo-lastest.tar.gz <urlopen error timed out>
The value should be a valid, public HTTP, HTTPS, or FTP URL.

0 packages and 1 specfiles checked; 0 errors, 2 warnings.

Perhaps the group should be either Applications/Productivity or Applications/Text.
 
- Some issue with the RPM:

amigo.noarch: I: checking
amigo.noarch: E: devel-dependency ruby-gtk2-devel
Your package has a dependency on a devel package but it's not a devel package
itself.

amigo.noarch: W: spelling-error Summary(en_US) spanish -> Spanish
The value of this tag appears to be misspelled. Please double-check.

amigo.noarch: W: non-standard-group System/Language
The value of the Group tag in the package is not valid.  Valid groups are:
"Amusements/Games", "Amusements/Graphics", "Applications/Archiving",
"Applications/Communications", "Applications/Databases",
"Applications/Editors", "Applications/Emulators", "Applications/Engineering",
"Applications/File", "Applications/Internet", "Applications/Multimedia",
"Applications/Productivity", "Applications/Publishing", "Applications/System",
"Applications/Text", "Development/Debug", "Development/Debuggers",
"Development/Languages", "Development/Libraries", "Development/System",
"Development/Tools", "Documentation", "System Environment/Base", "System
Environment/Daemons", "System Environment/Kernel", "System
Environment/Libraries", "System Environment/Shells", "User
Interface/Desktops", "User Interface/X", "User Interface/X Hardware Support".

amigo.noarch: W: no-version-in-last-changelog
The last changelog entry doesn't contain a version. Please insert the version
that is coherent with the version of the package and rebuild it.

amigo.noarch: I: checking-url http://gnomecoder.wordpress.com/amigo/ (timeout 10 seconds)
amigo.noarch: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.

amigo.noarch: E: non-standard-executable-perm /usr/bin/amigo 0775L
A standard executable should have permission set to 0755. If you get this
message, it means that you have a wrong executable permissions in some files
included in your package.

amigo.noarch: E: script-without-shebang /usr/bin/amigo
This text file has executable bits set or is located in a path dedicated for
executables, but lacks a shebang and cannot thus be executed.  If the file is
meant to be an executable script, add the shebang, otherwise remove the
executable bits or move the file elsewhere.

amigo.noarch: W: no-manual-page-for-binary amigo
Each executable in standard binary directories should have a man page.

1 packages and 0 specfiles checked; 3 errors, 5 warnings.

Note: I think you are mixing BuildRequires with Requires

Please take a look to:

- http://fedoraproject.org/wiki/Packaging/Guidelines
- http://fedoraproject.org/wiki/PackageMaintainers/Packaging_Tricks
- http://fedoraproject.org/wiki/Common_Rpmlint_issues

Hope that helps!

Comment 2 Yader Velásquez 2011-03-07 02:45:24 UTC
I'd been fixed the packages now available in:

Spec URL: http://yaderv.fedorapeople.org/rpm/amigo/amigo.spec       
SRPM URL: http://yaderv.fedorapeople.org/rpm/amigo/amigo-1.0-1.fc14.src.rpm 

the rpm lint output is:


amigo.src: W: spelling-error Summary(en_US) spanish -> Spanish
The value of this tag appears to be misspelled. Please double-check.

amigo.src: W: spelling-error %description -l en_US spanish -> Spanish
The value of this tag appears to be misspelled. Please double-check.

amigo.src: W: strange-permission amigo.sh 0775L
A file that you listed to include in your package has strange permissions.
Usually, a file should have 0644 permissions.

1 packages and 0 specfiles checked; 0 errors, 3 warnings.

I changed the permissions to 0775 to amigo.sh due is executable

Comment 3 Sergio Belkin 2011-03-07 05:03:08 UTC
In reply to comment #2)

Hi Yader

> I'd been fixed the packages now available in:
> 
> Spec URL: http://yaderv.fedorapeople.org/rpm/amigo/amigo.spec       
> SRPM URL: http://yaderv.fedorapeople.org/rpm/amigo/amigo-1.0-1.fc14.src.rpm 
> 
> the rpm lint output is:
> 
> 
> amigo.src: W: spelling-error Summary(en_US) spanish -> Spanish
> The value of this tag appears to be misspelled. Please double-check.
> 
> amigo.src: W: spelling-error %description -l en_US spanish -> Spanish
> The value of this tag appears to be misspelled. Please double-check.
> 
> amigo.src: W: strange-permission amigo.sh 0775L
> A file that you listed to include in your package has strange permissions.
> Usually, a file should have 0644 permissions.
> 
> 1 packages and 0 specfiles checked; 0 errors, 3 warnings.
> 
> I changed the permissions to 0775 to amigo.sh due is executable

-You meant 0755 isn't it? :)

-You should update the everytime you submit new files.

Look at this rpmlint output, my obs prefixed with "-" :

[sergio@peque usr]$ rpmlint -i -vv /var/lib/mock/fedora-14-i386/root/builddir/build/RPMS/amigo-1.0-1.fc14.noarch.rpm 
amigo.noarch: I: checking
amigo.noarch: W: spelling-error Summary(en_US) spanish -> Spanish
The value of this tag appears to be misspelled. Please double-check.

amigo.noarch: W: spelling-error %description -l en_US spanish -> Spanish
The value of this tag appears to be misspelled. Please double-check.

amigo.noarch: I: checking-url http://gnomecoder.wordpress.com/amigo/ (timeout 10 seconds)
amigo.noarch: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.


- Perhaps a README would be useful, you may ask to upstream to provide some documentation.

amigo.noarch: E: script-without-shebang /usr/bin/amigo
This text file has executable bits set or is located in a path dedicated for
executables, but lacks a shebang and cannot thus be executed.  If the file is
meant to be an executable script, add the shebang, otherwise remove the
executable bits or move the file elsewhere.

- It would be nicer this file content (in order to get rid of this warning) as follows:
#!/usr/bin/ruby
/usr/share/amigo/amigo.rb

amigo.noarch: W: no-manual-page-for-binary amigo
Each executable in standard binary directories should have a man page.

1 packages and 0 specfiles checked; 1 errors, 4 warnings.

HTH

Comment 4 Mario Blättermann 2012-08-26 18:50:00 UTC
Still anybody working on this package?

Comment 5 Yader Velásquez 2012-08-26 23:06:43 UTC
I have forgot this package because others, I will contact to the developer to see the state of development and finish the process this week.

Comment 6 Mario Blättermann 2012-09-09 19:50:33 UTC
Any news...?

Comment 7 Yader Velásquez 2012-09-10 15:19:46 UTC
Well, the last release was 4 years ago (2008). I think doesn't worth the package.

Comment 8 Mario Blättermann 2012-09-11 17:49:32 UTC
(In reply to comment #7)
> Well, the last release was 4 years ago (2008). I think doesn't worth the
> package.

OK, I close this review request now and add it to the FE-DEADREVIEW tracker.


Note You need to log in before you can comment on or make changes to this bug.