Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6817 - does not reread BSD partitions
Summary: does not reread BSD partitions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux
Version: 6.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-08 09:30 UTC by henrik.nordstrom
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-02-06 21:31:55 UTC


Attachments (Terms of Use)

Description henrik.nordstrom 1999-11-08 09:30:16 UTC
fdisk does not tell the kernel to reread the partition table
on changes to a BSD label (BSD labels is required by the
aboot loader).

As a work-around I use the attached program, or reboot the
machine.

int main(int argc, char **argv)
{
  int fd;

  fd = open(argv[1],O_RDONLY);
  errno = 0;
  ioctl(fd,BLKRRPART);
  return errno;
}

Comment 1 Cristian Gafton 2000-02-17 23:41:59 UTC
This is normal and expected behavior for a busy device - you can not invalidate
it.


*** This bug has been marked as a duplicate of 8082 ***

Comment 2 henrik.nordstrom 2000-02-18 09:06:59 UTC
The device IS NOT BUSY!

fdisk does not even ask the kernel to reread the partition table when modifying
a BSD label.

Comment 3 henrik.nordstrom 2000-02-18 09:17:59 UTC
BSD labels are accessed by entering b at the fdisk main menu prompt, which
causes fdisk to switch mode to BSD labels instead of DOS labels.

The same problem is also available in the minlabel utility (specific utility
only for BSD labels).

Comment 4 henrik.nordstrom 2000-02-18 09:19:59 UTC
Forgot to mention the versions currently tested:

# rpm -q -f /sbin/fdisk /sbin/minlabel
util-linux-2.9w-28
minlabel-1.2-6

Comment 5 Cristian Gafton 2000-05-22 15:57:59 UTC
assigned to jbj

Comment 6 Erik Troan 2001-02-06 21:31:51 UTC
This has been fixed in util-linux for quite a while.


Note You need to log in before you can comment on or make changes to this bug.