Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 68169 - RFE: Still no way to config DEMAND and PERSIST option for xDSL
Summary: RFE: Still no way to config DEMAND and PERSIST option for xDSL
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 81720
TreeView+ depends on / blocked
 
Reported: 2002-07-07 11:54 UTC by Bernd Bartmann
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-07-29 16:04:12 UTC


Attachments (Terms of Use)
Sample ifcfg-ppp0 with dial-on-demand support for T-DSL (deleted)
2002-08-02 08:13 UTC, Bernd Bartmann
no flags Details | Diff

Description Bernd Bartmann 2002-07-07 11:54:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
For RedHat 7.2 I reported this as bug 56210 ages ago. Now in LIMBO I still
cannot configure the DEMAND and PERSIST options for xDSL connections via PPPoe.
These options are essential for the common german T-DSL dial-on-demand connections.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. setup a xDSL connection using neat
2. try to set the DEMAND and PERSIST options for PPPoe
3.
	

Additional info:

Comment 1 Harald Hoyer 2002-07-08 15:42:27 UTC
added PERSIST

Comment 2 Michael Schwendt 2002-07-19 14:10:21 UTC
Unless I'm mistaken, it's DEMAND that doesn't get set in ifcfg-ppp* and cannot
be configured from redhat-config-network.

pppd option "persist" is added automatically in rp-pppoe's /sbin/adsl-connect
when DEMAND=yes.


Comment 3 Ngo Than 2002-08-01 21:02:28 UTC
i don't want to add support "dial on demand" yet, because it does not work well
with dynamic IP.As i know, T-DSL providers dynamic IP!


Comment 4 Bernd Bartmann 2002-08-01 21:21:12 UTC
What does not work well with dial-on-demand for you? I'm using rpppoe as
provided by Red Hat 7.x since over a year now without a single problem using
dial-on-demand and dynamic IPs. The only thing I had to do, was to configure the
PERSIST and DEMAND options in ifcfg-ppp*.

Comment 5 Ngo Than 2002-08-01 22:29:25 UTC
Could you please attach your modified ifcfg-ppp*. Thanks

Comment 6 Bernd Bartmann 2002-08-02 08:13:25 UTC
Created attachment 68425 [details]
Sample ifcfg-ppp0 with dial-on-demand support for T-DSL

Comment 7 Bernd Bartmann 2002-08-02 08:16:32 UTC
Just created the requested attachment (username and password set to dummy
values). If I remember correctly I only added PERSIST=yes and DEMAND=600.

Comment 8 Bernd Bartmann 2002-08-20 14:00:15 UTC
This feature is still missing in the new (Null) beta.


Note You need to log in before you can comment on or make changes to this bug.