Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6784 - kaudioserver and kwmsound not started in startkde - wrong file referenced
Summary: kaudioserver and kwmsound not started in startkde - wrong file referenced
Keywords:
Status: CLOSED DUPLICATE of bug 6589
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-06 23:23 UTC by Miloslav Trmac
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-23 16:04:51 UTC


Attachments (Terms of Use)

Description Miloslav Trmac 1999-11-06 23:23:26 UTC
The /usr/bin/startkde script references /etc/sysconfig/sound, which
doesn't exist (on my system, at least, and sndconfig doesn't create one).
The result is that kaudioserver and kwmsound are not started,
regardless of whether there is a soundcard in the computer. I think that
the needed file is /etc/sysconfig/soundcard.

Moreover, sndconfig puts a localized comment to the start of
/etc/sysconfig/soundcard (LANG=cs, LC_ALL=cs_CZ), which
somehow confuses bash, so that
.: /etc/sysconfig/souncard: cannot execute binary file
appears in .xsession-errors and the CARDTYPE variable is not set
either. Putting a line of
#!/bin/bash
at the start of /etc/sysconfig/soundcard fixes it, which IMHO should be
done by sndconfig alone.
Thanks for the time you spent with it.
Mirek

Comment 1 Preston Brown 1999-11-23 16:04:59 UTC
*** This bug has been marked as a duplicate of 6589 ***


Note You need to log in before you can comment on or make changes to this bug.