Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 67758 - ftp transfers are very slow, 500MB takes 2 hours.
Summary: ftp transfers are very slow, 500MB takes 2 hours.
Keywords:
Status: CLOSED DUPLICATE of bug 78616
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-01 18:22 UTC by Karen
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-07-02 19:02:11 UTC


Attachments (Terms of Use)

Description Karen 2002-07-01 18:22:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ftp a file from this box to another Linux box
2. ftp a file from this box to another HP box
3. ftp a file to this box from either above. All Linux builds on IBM xseries 
rack mounts are behaving the same.
	

Actual Results:  The ftp works but it takes a couple of hours for just a 500MB 
file.

Expected Results:  Should happen pretty fast.

Additional info:

Comment 1 Bernhard Rosenkraenzer 2002-07-02 10:21:55 UTC
This can have a number of reasons, and wu-ftpd isn't likely to be the culprit. 
It is much more likely that the driver for your network card isn't performing 
well. 
 
- What network card are you using? 
- Does the same happen if you use "ftp localhost" to download the file? 


Comment 2 Karen 2002-07-02 13:57:28 UTC
This is a standard integrated adapter on the IBM xseries 330, 10/100 Mbps. I 
tried to ftp to localhost and it does seem to be fast.

How do I tell what driver it is using?

Thanks

Comment 3 Bernhard Rosenkraenzer 2002-07-02 14:02:34 UTC
You can tell which driver you are using by looking at the output of lsmod. 
It lists all currently loaded kernel modules [mostly drivers]. 
 
Since ftp localhost is not affected, this is almost certainly driver related; 
changing component.

Comment 4 Karen 2002-07-02 14:17:08 UTC
# lsmod
Module                  Size  Used by
mvfs                  303136   2 
nfs                    79008   5  (autoclean)
lockd                  52464   1  (autoclean) [nfs]
sunrpc                 61328   1  [mvfs nfs lockd]
eepro100               16624   1  (autoclean)
ipchains               38976   0  (unused)
usb-ohci               17104   0  (unused)
usbcore                49664   1  [usb-ohci]
aic7xxx               136080   7 
sd_mod                 11680   7 
scsi_mod               95072   2  [aic7xxx sd_mod]

Comment 5 Arjan van de Ven 2002-07-02 16:21:36 UTC
What kernel version are you actually running? If it's not 2.4.9-31, 2.4.9-34 or
2.4.18-5, please upgrade to that first since that has a bugfixed eepro100 driver.

Comment 6 Karen 2002-07-02 19:02:06 UTC
I am currently at 2.4.2-2. I'll try upgrading and see if that fixes. Thanks!

Comment 7 Arjan van de Ven 2002-12-05 20:11:19 UTC

*** This bug has been marked as a duplicate of 78616 ***

Comment 8 Karen 2003-01-28 22:06:18 UTC
Found the problem! Slow ftp caused by the ethernet switch being set to 
autonegotiate, while the Linux server was set to 100FD. Did a # mii-tool eth0 
to find the correct speed of the NIC.


Note You need to log in before you can comment on or make changes to this bug.