Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6772 - Multiple Adaptec SCSI cards get loaded in the wrong order
Summary: Multiple Adaptec SCSI cards get loaded in the wrong order
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
: 8038 8044 8324 10097 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-06 05:46 UTC by kevinmills
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-22 15:08:02 UTC


Attachments (Terms of Use)

Description kevinmills 1999-11-06 05:46:01 UTC
During the install, my Adaptec 2940UW was detected and my
hard drive was found as /dev/sda.  My CDROM and Jaz drive
are on an Adaptec 1542 and, after choosing that driver, the
Jaz was detected as /dev/sdb.  Installation proceeded
normally.  However, upon re-boot the Adaptec 1542 driver
was loaded first causing my Jaz to be /dev/sda.  The
aic7xxx driver loaded next and made my hard
drive /dev/sdb.  This caused a kernel panic - no root fs.

My /etc/conf.modules file *does* list them in the correct
order; the aic7xxx driver is first and labled
scsi_hostadapter and the 1542 driver is second and labled
scsi_hostadapter1.  However, they do not load in this order.

Comment 1 Jay Turner 1999-11-09 15:54:59 UTC
I am forwarding this to a developer for further action, but in the
mean time, you can try the following and see if it helps you out.

In conf.modules, on the aic7xxx line, add "aic7xxx reverse_scan"
which should force recognition in the reverse order.

Comment 2 kevinmills 1999-11-18 22:40:59 UTC
More info:

adding the reverse_scan line did *not* change the behavior.

Comment 3 Anonymous 1999-12-01 19:01:59 UTC
I had the same problem with two SCSI adapters. I fixed it by changing
scsi_hostadapter to scsi_hostadapter0 for the adapter that the hard drive is on
(and leaving scsi_hostadapter1 for the adapter that my SCSI zip drive is on.  It
appears that the one for the second card is ignored unless you have a zero for
the first card

Comment 4 Jay Turner 2000-02-10 02:37:59 UTC
*** Bug 8324 has been marked as a duplicate of this bug. ***

Comment 5 Jay Turner 2000-02-10 02:45:59 UTC
*** Bug 8044 has been marked as a duplicate of this bug. ***

Comment 6 Jay Turner 2000-02-10 03:13:59 UTC
*** Bug 8038 has been marked as a duplicate of this bug. ***

Comment 7 kevinmills 2000-02-10 17:17:59 UTC
I tried adding a '0' to scsi_hostadapter and saw no difference.  It behaved
exactly the same no matter which card was scsi_hostadapter0 or 1.

Comment 8 Jay Turner 2000-02-22 15:07:59 UTC
This issue is resolved in the latest cut of the installer (available in beta)

Comment 9 Bill Nottingham 2000-03-09 19:48:59 UTC
*** Bug 10097 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.