Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6768 - /bin/echo does not process escape char \n
Summary: /bin/echo does not process escape char \n
Keywords:
Status: CLOSED DUPLICATE of bug 6498
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL: http://www.resonate.com
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-05 23:24 UTC by jcassell
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-09 16:27:02 UTC


Attachments (Terms of Use)

Description jcassell 1999-11-05 23:24:52 UTC
/bin/echo and echo no longer interpret the newline escape
character embedded in a string. E.G.

TMP="This is some text"
TMP=${TMP}"\nwith a newline in the middle"

/bin/echo ${TMP}

This code work fine in 6.0 and other flavors of unix:

This is some text
with a newline in the middle

but in RH 6.1 this is the output:

This is some text\nwith a newline in the middle

This bug has cost us a lot of time and money! What are you
guys smoking over there?! (sorry)

Comment 1 jcassell 1999-11-08 20:16:59 UTC
BTW, I neglected to mention, the bug-like echo behavior is exhibited
in a Bourne shell script - i.e. #!/bin/sh.

Comment 2 Bill Nottingham 1999-11-09 16:27:59 UTC
*** This bug has been marked as a duplicate of 6498 ***


Note You need to log in before you can comment on or make changes to this bug.