Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 676263 - Package Review: perl-NetAddr-IP - Manages IPv4 and IPv6 addresses and subnets
Summary: Package Review: perl-NetAddr-IP - Manages IPv4 and IPv6 addresses and subnets
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Package Review
Version: 5.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Petr Šabata
QA Contact:
URL:
Whiteboard:
Depends On: perl-NetAddr-IP
Blocks: 524225
TreeView+ depends on / blocked
 
Reported: 2011-02-09 09:22 UTC by Marcela Mašláňová
Modified: 2011-03-09 16:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-09 16:27:46 UTC


Attachments (Terms of Use)

Comment 1 Petr Pisar 2011-02-09 09:35:43 UTC
There is a typo in description:

NetAdder::IP will will work

Comment 2 Petr Šabata 2011-03-08 13:37:33 UTC
- rpmlint output
    perl-NetAddr-IP.x86_64: W: private-shared-object-provides /usr/lib64/perl5/auto/NetAddr/IP/)(64bit)
+ package name satisfies the packaging naming guidelines
+ specfile name matches the package base name
+ package should satisfy packaging guidelines
+ license meets guidelines and is acceptable to Fedora
+ license matches the actual package license
    Artistic 2.0, notes included
+ %doc includes license file
- spec file written in American English
    19:s/NetAdder::IP will will/NetAddr::IP will/
+ spec file is legible
- upstream sources match sources in the srpm
    Cannot be checked since upstream no longer provides the packaged version
+ package successfully builds on at least one architecture
    (checked on x86-64)
n/a ExcludeArch bugs filed
+ BuildRequires list all build dependencies
n/a %find_lang instead of %{_datadir}/locale/*
n/a binary RPM with shared library files must call ldconfig in %post and %postun
+ does not use Prefix: /usr
+ package owns all directories it creates
+ no duplicate files in %files
+ %defattr line
+ %clean contains rm -rf $RPM_BUILD_ROOT
    %{buildroot} used
+ consistent use of macros
+ package must contain code or permissible content
n/a large documentation files should go in -doc subpackage
+ files marked %doc should not affect package
n/a header files should be in -devel
n/a static libraries should be in -static
n/a packages containing pkgconfig (.pc) files need 'Requires: pkgconfig'
n/a libfoo.so must go in -devel
n/a -devel must require the fully versioned base
n/a packages should not contain libtool .la files
n/a packages containing GUI apps must include %{name}.desktop file
n/a packages must not own files or directories owned by other packages
+ %install must start with rm -rf %{buildroot} etc.
+ filenames must be valid UTF-8

Optional:

+ if there is no license file, packager should query upstream
n/a translations of description and summary for non-English languages, if available
+ reviewer should build the package in mock
+ the package should build into binary RPMs on all supported architectures
+ review should test the package functions as described
    All tests pass
n/a scriptlets should be sane
n/a pkgconfig files should go in -devel
+ shouldn't have file dependencies outside /etc /bin /sbin /usr/bin or /usr/sbin

Other:

Requires:
libc.so.6()(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libc.so.6(GLIBC_2.3.4)(64bit)  
libc.so.6(GLIBC_2.4)(64bit)  
perl(:MODULE_COMPAT_5.8.8)  
perl(AutoLoader)  
perl(Carp)  
perl(DynaLoader)  
perl(Exporter)  
perl(NetAddr::IP::Lite) >= 1.13
perl(NetAddr::IP::Util)  
perl(NetAddr::IP::Util) >= 1.30
perl(NetAddr::IP::Util_IS)  
perl(strict)  
perl(vars)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
rtld(GNU_HASH)  

Provides:
Util.so()(64bit)  
perl(NetAddr::IP) = 4.27
perl(NetAddr::IP::Lite) = 1.13
perl(NetAddr::IP::Util) = 1.31
perl(NetAddr::IP::UtilPP) = 1.7
perl(NetAddr::IP::Util_IS) = 1.00
perl-NetAddr-IP = 4.027-3.el5


Summary:

- The typos in description should be corrected
- The package shouldn't require NetAddr::IP::Util (unversioned)
- The package shouldn't provide Util.so
- Note: Upstream no longer provides sources for this version
- NOT APPROVED

Comment 3 Marcela Mašláňová 2011-03-09 16:15:25 UTC
(In reply to comment #2)
> 
> Summary:
> 
> - The typos in description should be corrected
Fixed
> - The package shouldn't require NetAddr::IP::Util (unversioned)
Fixed
> - The package shouldn't provide Util.so
Only warning, our old filter is not able remove this provide.
> - Note: Upstream no longer provides sources for this version
But we have this version in RHEL-6 and we shouldn't have newer in RHEL-5. Even if update between RHEL is not supported, we shouldn't have newer releases in older RHELs.
> - NOT APPROVED

See:
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=3167891

Comment 4 Petr Šabata 2011-03-09 16:23:03 UTC
Looks and builds okay now, approving.


Note You need to log in before you can comment on or make changes to this bug.