Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6762 - sort does not follow follow POSIX behavior
Summary: sort does not follow follow POSIX behavior
Keywords:
Status: CLOSED DUPLICATE of bug 6569
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: textutils
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-05 15:42 UTC by djschaap
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-14 03:45:50 UTC


Attachments (Terms of Use)

Description djschaap 1999-11-05 15:42:51 UTC
Under RedHat 6.0, sort has (for me anyway) followed
POSIX-specified behavior of case-sensitive sorting.  Doing a
fresh install of Redhat 6.1 (and selecting en_US during
install) causes sort to do case-insensitive searches.
Upgrading an existing RedHat 6.0 system to RH 6.1 does not
alter sort's behavior (ie, it remains case-sensitive).  It
appears the new textutils package improperly uses the
"locale" setting.  (IMO anyway -- I think sort should
*always* default to case-sensitive sorting to maintain
compatibility with other distros / Unices)

Is there a fix for this?  If not, how can I change the
locale on a RH 6.1 box?

Comment 1 djschaap 1999-11-05 15:59:59 UTC
I've changed /etc/sysconfig/i18n to {LANG,LC_ALL,LINGUAS}=POSIX (from
en_US) for now.  This seems to be a decent workaround.

Comment 2 Bill Nottingham 1999-11-05 16:24:59 UTC
Sort is correctly following the LC_COLLATE settings in
the en_US locale. However, the correctness of those
locale settings is a matter of question....

Comment 3 Preston Brown 2000-01-14 03:45:59 UTC
*** This bug has been marked as a duplicate of 6569 ***


Note You need to log in before you can comment on or make changes to this bug.