Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 67478 - Value Error: invalid literal for long()
Summary: Value Error: invalid literal for long()
Keywords:
Status: CLOSED DUPLICATE of bug 64711
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 7.3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-25 23:57 UTC by Nancy Van Cleave
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-06-26 00:00:16 UTC


Attachments (Terms of Use)
Error msg and values saved by installer (deleted)
2002-06-26 00:00 UTC, Nancy Van Cleave
no flags Details

Description Nancy Van Cleave 2002-06-25 23:57:45 UTC
Description of Problem:  
During installation while checking for bad blocks, the "Value Error: invalid
literal for long(): 2943872" message appears, ending the installation.


Version-Release number of selected component (if applicable):
Red Hat Linux 7.3

How Reproducible:
Ask to (repartition and) check for bad blocks on the hard drive.  This error has
occurred on both a laptop and a workstation installation

Steps to Reproduce:
1. Request check for bad blocks
2. 
3. 

Actual Results:
Error and Termination of installation

Expected Results:
Discovery of bad blocks, marking them as unusable if found, then continuation of
installation

Additional Information:  The following is the error messaged was saved in
"anacdump.txt" -- there's more info in the file if you want it.

Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 375, in turnOnFilesystems
    thefsset.checkBadblocks(instPath)
  File "/usr/lib/anaconda/fsset.py", line 1007, in checkBadblocks
    self.badblocksEntry(entry, chroot)
  File "/usr/lib/anaconda/fsset.py", line 984, in badblocksEntry
    entry.fsystem.badblocksDevice(entry, self.progressWindow, chroot)
  File "/usr/lib/anaconda/fsset.py", line 211, in badblocksDevice
    val = (long(l[0]) * 100) / long(l[1])
ValueError: invalid literal for long(): 2943872
  2943873

Comment 1 Nancy Van Cleave 2002-06-26 00:00:12 UTC
Created attachment 62644 [details]
Error msg and values saved by installer

Comment 2 Michael Fulbright 2002-06-26 04:59:38 UTC
The bad blocks check discovered bad blocks, and there is a bug in the reporting
of this fact.

We've fixed this reporting error in CVS.

Basically your drive has problems and the bad blocks check uncovered them.

*** This bug has been marked as a duplicate of 64711 ***


Note You need to log in before you can comment on or make changes to this bug.