Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 67285 - aha152x fails to work in the 2.4.18-5 kernel for pcmcia scsi card
Summary: aha152x fails to work in the 2.4.18-5 kernel for pcmcia scsi card
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-21 21:28 UTC by George H. Fisher
Modified: 2007-04-18 16:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-07 19:12:04 UTC


Attachments (Terms of Use)

Description George H. Fisher 2002-06-21 21:28:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011126
Netscape6/6.2.1

Description of problem:
In the 2.4.18-5 kernel, installed after running "up2date" recently, the aha152x
scsi module no longer enables my pcmcia scsi card to be recognized.  The card
*does* work with the 2.4.18-4 kernel.  The exact output from dmesg with the
2.4.18-5 kernel is: aha152x: processing commandline: ok
aha152x: BIOS test: passed, detected 1 controller(s)
aha152x: resetting bus...
aha152x1: vital data: rev=1, io=0x340 (0x340/0x340), irq=5, scsiid=7,
reconnect=enabled, parity=enabled, synchronous=disabled, delay=100, extended
translation=disabled
aha152x1: trying software interrupt, lost.
aha152x1: IRQ 5 possibly wrong.  Please verify.
aha152x_cs: no SCSI devices found
Trying to free nonexistent resource <00000340-0000035f>
--------------------------------------------------------------

Here is what happens under the 2.4.18-4 kernel, where it does work:

------------------------------------------------------------------
aha152x: processing commandline: ok
aha152x: BIOS test: passed, detected 1 controller(s)
aha152x: resetting bus...
aha152x1: vital data: rev=1, io=0x340 (0x340/0x340), irq=5, scsiid=7,
reconnect=enabled, parity=enabled, synchronous=disabled, delay=100, extended
translation=disabled
aha152x1: trying software interrupt, <6>eth0: flipped to 10baseT
ok.
scsi1 : Adaptec 152x SCSI driver; $Revision: 2.4 $
  Vendor: iomega    Model: jaz 2GB           Rev: E.17
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi1, channel 0, id 4, lun 0
SCSI device sda: 3915600 512-byte hdwr sectors (2005 MB)
sda: Write Protect is off
 sda: sda4



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert pcmcia scsi card into slot, attach to jaz drive
2. Boot up with the 2.4.18-5 kernel
3.
	

Actual Results:  Output from dmesg:

aha152x: processing commandline: ok
aha152x: BIOS test: passed, detected 1 controller(s)
aha152x: resetting bus...
aha152x1: vital data: rev=1, io=0x340 (0x340/0x340), irq=5, scsiid=7,
reconnect=enabled, parity=enabled, synchronous=disabled, delay=100, extended
translation=disabled
aha152x1: trying software interrupt, lost.
aha152x1: IRQ 5 possibly wrong.  Please verify.
aha152x_cs: no SCSI devices found
Trying to free nonexistent resource <00000340-0000035f>

After this, any devices hooked up to scsi card are inaccessible.


Expected Results:  Here is what happens under 2.4.18-4 kernel, where it works:

aha152x: processing commandline: ok
aha152x: BIOS test: passed, detected 1 controller(s)
aha152x: resetting bus...
aha152x1: vital data: rev=1, io=0x340 (0x340/0x340), irq=5, scsiid=7,
reconnect=enabled, parity=enabled, synchronous=disabled, delay=100, extended
translation=disabled
aha152x1: trying software interrupt, <6>eth0: flipped to 10baseT
ok.
scsi1 : Adaptec 152x SCSI driver; $Revision: 2.4 $
  Vendor: iomega    Model: jaz 2GB           Rev: E.17
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi1, channel 0, id 4, lun 0
SCSI device sda: 3915600 512-byte hdwr sectors (2005 MB)
sda: Write Protect is off
 sda: sda4


Additional info:

Comment 1 Carlos Rodrigues 2002-06-21 23:59:02 UTC
I have a ISA scsi card suported by the aha152x driver and I find it is also 
broken on 2.4.18-5 although it worked perfectly fine with 2.4.18-4. I even 
tried changing the irq and io settings on the card. 
 
Output from dmesg is similar to the above and it is: 
 
aha152x: BIOS test: passed, detected 1 controller(s) 
aha152x: resetting bus... 
aha152x0: vital data: rev=1, io=0x140 (0x140/0x140), irq=11, scsiid=7, 
reconnect=enabled, parity=enabled, synchronous=disabled, delay=1000, extended 
translation=disabled 
aha152x0: trying software interrupt, lost. 
aha152x0: IRQ 11 possibly wrong.  Please verify. 
aha152x: BIOS test: passed, detected 1 controller(s) 
aha152x: resetting bus... 
aha152x0: vital data: rev=1, io=0x140 (0x140/0x140), irq=11, scsiid=7, 
reconnect=enabled, parity=enabled, synchronous=disabled, delay=1000, extended 
translation=disabled 
aha152x0: trying software interrupt, lost. 
aha152x0: IRQ 11 possibly wrong.  Please verify. 


Comment 2 Carlos Rodrigues 2002-06-22 00:01:13 UTC
The output is posted twice above... my mistake.

Comment 3 Arjan van de Ven 2002-06-22 14:51:36 UTC
I think I found the cause, could you guys try the 2.4.18-5a kernel from

http://people.redhat.com/arjanv/testkernels

?

Comment 4 George H. Fisher 2002-06-24 03:36:33 UTC
Hi Arjan,

I just tried the new kernel, and now the aha152x driver seems to work fine.  I
hooked up my pcmcia scsi card (labeled as a "jaz" card) up to my hp m820e cd
burner and burned a cd.  It worked fine, at least for my setup.  Thanks for your
help!

Best, - George

Comment 5 Pierre Thonne 2002-06-24 19:32:26 UTC
I've also the same problem with kernel 2.4.18-5. 
Here is the log :

Jun 24 21:11:25 TooneMach kernel: Linux Kernel Card Services 3.1.22
Jun 24 21:11:25 TooneMach kernel:   options:  [pci] [cardbus] [pm]
Jun 24 21:11:25 TooneMach kernel: PCI: Found IRQ 11 for device 00:03.0
Jun 24 21:11:25 TooneMach kernel: PCI: Sharing IRQ 11 with 00:03.1
Jun 24 21:11:25 TooneMach kernel: PCI: Sharing IRQ 11 with 00:07.2
Jun 24 21:11:25 TooneMach kernel: PCI: Found IRQ 11 for device 00:03.1
Jun 24 21:11:25 TooneMach kernel: PCI: Sharing IRQ 11 with 00:03.0
Jun 24 21:11:25 TooneMach kernel: PCI: Sharing IRQ 11 with 00:07.2
Jun 24 21:11:25 TooneMach kernel: Yenta IRQ list 06b8, PCI irq11
Jun 24 21:11:25 TooneMach kernel: Socket status: 30000010
Jun 24 21:11:25 TooneMach kernel: Yenta IRQ list 06b8, PCI irq11
Jun 24 21:11:25 TooneMach kernel: Socket status: 30000010
Jun 24 21:11:26 TooneMach cardmgr[2969]: starting, version is 3.1.22
Jun 24 21:11:26 TooneMach cardmgr[2969]: config error, file './config.opts' line
6: no function bindings
Jun 24 21:11:26 TooneMach cardmgr[2969]: watching 2 sockets
Jun 24 21:11:26 TooneMach kernel: cs: IO port probe 0x1000-0x17ff: clean.
Jun 24 21:11:26 TooneMach kernel: cs: IO port probe 0x0100-0x04ff: excluding
0x280-0x287 0x4d0-0x4d7Jun 24 21:11:26 TooneMach cardmgr[2969]: initializing
socket 0
Jun 24 21:11:26 TooneMach kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean.
Jun 24 21:11:26 TooneMach cardmgr[2969]: socket 0: D-Link DE-660 Ethernet
Jun 24 21:11:26 TooneMach cardmgr[2969]: executing: 'modprobe 8390'
Jun 24 21:11:26 TooneMach cardmgr[2969]: executing: 'modprobe pcnet_cs'
Jun 24 21:11:27 TooneMach kernel: eth0: NE2000 Compatible: io 0x300, irq 5,
hw_addr 00:80:C8:8B:8B:C7
Jun 24 21:11:27 TooneMach cardmgr[2969]: executing: './network start eth0'
Jun 24 21:11:27 TooneMach /etc/hotplug/net.agent: invoke ifup eth0
Jun 24 21:11:27 TooneMach cardmgr[2969]: initializing socket 1
Jun 24 21:11:27 TooneMach cardmgr[2969]: socket 1: Adaptec APA-1460 SlimSCSI
Jun 24 21:11:27 TooneMach cardmgr[2969]: executing: 'modprobe aha152x_cs
irq_list=9,10 reset_delay=500 synchronous=0 ext_trans=1'
Jun 24 21:11:27 TooneMach cardmgr[2969]: get dev info on socket 1 failed: No
such device
Jun 24 21:11:27 TooneMach kernel: aha152x: processing commandline: ok
Jun 24 21:11:27 TooneMach kernel: aha152x: BIOS test: passed, detected 1
controller(s)
Jun 24 21:11:27 TooneMach kernel: aha152x: resetting bus...
Jun 24 21:11:27 TooneMach kernel: aha152x0: vital data: rev=1, io=0x340
(0x340/0x340), irq=9, scsiid=7, reconnect=enabled, parity=enabled,
synchronous=disabled, delay=500, extended translation=enabledJun 24 21:11:27
TooneMach kernel: aha152x0: trying software interrupt, lost.
Jun 24 21:11:27 TooneMach kernel: aha152x0: IRQ 9 possibly wrong.  Please verify.
Jun 24 21:11:27 TooneMach kernel: aha152x_cs: no SCSI devices found
Jun 24 21:11:27 TooneMach kernel: Trying to free nonexistent resource
<00000340-0000035f>
Jun 24 21:15:13 TooneMach kernel: loop: loaded (max 8 devices)
[root@TooneMach root]#

Comment 6 Carlos Rodrigues 2002-06-25 15:04:09 UTC
2.4.18-5a works fine for me also.

Comment 7 Need Real Name 2002-07-17 03:58:52 UTC
I also could not use the aha152x module with 2.4.18-5.  It worked
fine with 2.4.18-3.  2.4.18-5a no longer existed in the testkernel
directory.  I downloaded 2.4.18-5e instead (no other choice) for i686.
The module now loads properly.

Comment 8 m.oliver 2002-08-06 18:37:44 UTC
I still have problems using an Adaptec AVA-1505 card with the latest
test kernel (with scanner Scanmaker e3 plus attached):

History of the problem:

**************************************
WORKS FINE: kernel-2.4.7-10.athlon.rpm
**************************************

Aug  6 18:54:09 hoelderlin kernel: Linux version 2.4.7-10
(bhcompile@stripples.devel.redhat.com) (gcc version 2.96 20000731 (Red Hat Linux
7.1 2.96-98)) #1 Thu Sep 6 16:46:36 EDT 2001
Aug  6 18:54:10 hoelderlin kernel: SCSI subsystem driver Revision: 1.00
Aug  6 18:54:10 hoelderlin kernel: aha152x: BIOS test: passed, detected 1
controller(s)
Aug  6 18:54:10 hoelderlin kernel: aha152x: resetting bus...
Aug  6 18:54:10 hoelderlin kernel: aha152x0: vital data: rev=3, io=0x140
(0x140/0x140), irq=9, scsiid=7, reconnect=enabled, parity=enabled,
synchronous=disabled, delay=1000, extended translation=disabled
Aug  6 18:54:10 hoelderlin kernel: aha152x0: trying software interrupt, ok.
Aug  6 18:54:10 hoelderlin kernel: scsi0 : Adaptec 152x SCSI driver; $Revision:
2.4 $

**************************************
COMPLETELY BROKEN SINCE 2.4.9-21
LOG FROM kernel-2.4.18-5.athlon.rpm 
**************************************

Aug  6 18:49:05 hoelderlin kernel: Linux version 2.4.18-5
(bhcompile@porky.devel.redhat.com) (gcc version 2.96 20000731 (Red Hat Linux 7.3
2.96-110)) #1 Mon Jun 10 15:37:14 EDT 2002
Aug  6 18:49:13 hoelderlin kernel: aha152x: BIOS test: passed, detected 1
controller(s)
Aug  6 18:49:13 hoelderlin kernel: aha152x: resetting bus...
Aug  6 18:49:13 hoelderlin kernel: aha152x1: vital data: rev=3, io=0x140
(0x140/0x140), irq=9, scsiid=7, reconnect=enabled, parity=enabled,
synchronous=disabled, delay=1000, extended translation=disabled
Aug  6 18:49:13 hoelderlin kernel: aha152x1: trying software interrupt, lost.
Aug  6 18:49:13 hoelderlin kernel: aha152x1: IRQ 9 possibly wrong.  Please verify.

***********************************************************
CARD WORKS, BUT SCANNER DOESN'T: kernel-2.4.18-7.athlon.rpm
***********************************************************

Aug  6 20:13:12 hoelderlin kernel: Linux version 2.4.18-7
(bhcompile@porky.devel.redhat.com) (gcc version 2.96 20000731 (Red Hat Linux 7.3
2.96-110)) #1 Mon Jul 22 07:54:58 EDT 2002
Aug  6 20:13:21 hoelderlin kernel: aha152x: BIOS test: passed, detected 1
controller(s)
Aug  6 20:13:21 hoelderlin dhcpd: 
Aug  6 20:13:21 hoelderlin kernel: aha152x: resetting bus...
Aug  6 20:13:21 hoelderlin dhcpd: Please contribute if you find this software
useful.
Aug  6 20:13:21 hoelderlin kernel: aha152x0: vital data: rev=3, io=0x140
(0x140/0x140), irq=9, scsiid=7, reconnect=enabled, parity=enabled,
synchronous=disabled, delay=1000, extended translation=disabled
Aug  6 20:13:21 hoelderlin kernel: aha152x0: trying software interrupt, spurious
8259A interrupt: IRQ7.
Aug  6 20:13:21 hoelderlin kernel: ok.
Aug  6 20:13:21 hoelderlin kernel: scsi0 : Adaptec 152x SCSI driver; $Revision:
2.4$
Aug  6 20:13:21 hoelderlin kernel:   Vendor:           Model: Scanner 300A4    
Rev: 5.12
Aug  6 20:13:21 hoelderlin kernel:   Type:   Scanner  

When trying to use the scanner, the following happens (for some reason
kernel seems to think it's an ide-scsi device, which it isn't):

Aug  6 20:14:17 hoelderlin modprobe: modprobe: Can't locate module char-major-81
Aug  6 20:14:17 hoelderlin last message repeated 3 times
Aug  6 20:14:17 hoelderlin kernel: Attached scsi generic sg0 at scsi0, channel
0, id 6, lun 0,  type 6
Aug  6 20:14:17 hoelderlin kernel: ide-scsi: The scsi wants to send us more data
than expected - discarding data
Aug  6 20:14:17 hoelderlin kernel: ide-scsi: transferred 1 of 2 bytes

Comment 9 m.oliver 2002-08-12 06:49:58 UTC
The problem described in my previous comment is resolved, and not kernel related:
The 2.4.18 kernel permutes the numbering of scsi devices, so that /dev/scanner
was suddenly pointing to the CD writer.  

After fixing this, 2.4.18-7 works fine for me.

Comment 10 Broderick Wood 2002-08-15 06:11:47 UTC
I am running a desktop with an older (non-pci) Adaptec SCSI card that uses the
AHA152x driver which immediately failed with the 2.4.18-5 kernel update, but the
suggested 2.4.18-7 update installed and it seems fine now.


Comment 11 Carlos Rodrigues 2002-10-08 00:39:58 UTC
The problem is back in redhat 8.0

Comment 12 Need Real Name 2002-10-17 20:47:45 UTC
I have an Adaptec 1460 PCMCIA SCSI card that I'm using with RedHat 8.0
(2.4.18-14 kernel).  I see the same problem ("trying software interrupt, lost.")
when I insert the card.  Using Google, I was able to find some information about
this problem at http://www.uwsg.iu.edu/hypermail/linux/kernel/0207.2/0209.html.
 I modified aha152x.c as suggested in the post and rebuilt the kernel.  I am now
able to use my SCSI card.

I previously used this card under RedHat 7.1 and RedHat 7.2 without any problems.

Comment 13 Carlos Rodrigues 2002-10-17 22:06:35 UTC
The problem is fixed in the errata kernel 2.4.18-17.8.0.


Note You need to log in before you can comment on or make changes to this bug.