Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6715 - System locks up on boot time when bringing up eth0
Summary: System locks up on boot time when bringing up eth0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
: 6823 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-04 11:57 UTC by wastelands
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-06 05:29:55 UTC


Attachments (Terms of Use)

Description wastelands 1999-11-04 11:57:54 UTC
The machine locks up on boot time when bringing up the
eth0 (Intel EtherExpress Pro 100) interface. There are no
virual interfaces such as eth0:0 eth0:0 aso. For some
strange reason it doesn't always lock up, when you skip the
BIOS' memory check at boot time.


------- Additional Comments From   11/11/99 05:38 -------
!!! FIXED !!!

This is a bug in the Linux-Kernel. Rumours say, that Donald Becker the
author of the eepro100 driver, had an argument with Linus Torvalds
about the way Kernel-Patches should be applied and therefore doesn't
include _ANY_ updates of that driver in new Kernel releases.

Download the driver at:
http://cesdis.gfsc.nasa.gov/linux/drivers/eepro100.html
and replace the eepro100.c with the one in your favorite
kernel-source.

This driver (v1.09l) is a stable release and shouldn't hang your
machine.

Should you experience the problem, that the driver resets your
transmitter on high network load, then I highly recommend the
unofficial release v1.09r. This fixes the problem. Note that v1.09r is
a development release for the 2.3 Kernel - it works GREAT for me
though (using Kernel 2.2.13).

Comment 1 Cristian Gafton 2000-01-04 22:27:59 UTC
Assigned to dledford

Comment 2 Bill Nottingham 2000-02-06 05:29:59 UTC
*** Bug 6823 has been marked as a duplicate of this bug. ***

Comment 3 Alan Cox 2000-08-22 19:00:09 UTC
Actually the driver has another maintainer nowdays, not Donald for 2.2
The problem described (shared IRQ card hang on boot) was fixed in later kernels
by HJ Lu



Note You need to log in before you can comment on or make changes to this bug.