Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6709 - RP3 crashes with failed assertion
Summary: RP3 crashes with failed assertion
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rp3
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-04 05:10 UTC by randolph
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-04-28 08:47:27 UTC


Attachments (Terms of Use)

Description randolph 1999-11-04 05:10:49 UTC
After it's been left up for a long time (8+ hours) and
disconnected, rp3 crashes with a failed assertion--it has
done so twice.  Here's the gdb "where" output:

#0  0x4044f4e1 in __kill () from /lib/libc.so.6
#1  0x4044f156 in raise (sig=6) at
../sysdeps/posix/raise.c:27
#2  0x40450868 in abort () at ../sysdeps/generic/abort.c:88
#3  0x404493ce in __assert_fail (assertion=0x805526d
"i->physicalName",
    file=0x8054ff9 "interface.c", line=486,
    function=0x8055255 "interface_txrx_update") at
assert.c:59
#4  0x80514c0 in interface_txrx_update (i=0x809bdc8) at
interface.c:486
#5  0x804d8be in display_txrx_update (data=0x8098438) at
display.c:80
#6  0x4041ca04 in g_timeout_dispatch () from
/usr/lib/libglib-1.2.so.0
#7  0x4041bbe6 in g_main_dispatch () from
/usr/lib/libglib-1.2.so.0
#8  0x4041c1a1 in g_main_iterate () from
/usr/lib/libglib-1.2.so.0
#9  0x4041c341 in g_main_run () from
/usr/lib/libglib-1.2.so.0
#10 0x40233209 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#11 0x4001f2a5 in applet_widget_gtk_main () from
/usr/lib/libpanel_applet.so.0
#12 0x804d4d2 in applet_main (argc=3, argv=0xbffff894) at
rp3.c:70
#13 0x804d826 in main (argc=3, argv=0xbffff894) at rp3.c:167

Comment 1 Michael K. Johnson 1999-11-04 20:10:59 UTC
Thank you for finding this!  It's code rot -- a function originally
written to be called syncronously is being called async and thus the
assertion can be wrong.  I've fixed it for the next release of rp3;
when I make that release, I'll close this bug report.

Comment 2 Michael K. Johnson 1999-11-19 21:10:59 UTC
While I haven't made an official errata release yet as I'm waiting on some
feedback, rp3-1.0.2-1 is available in the meantime at
ftp://people.redhat.com/johnsonm/rp3/rp3-1.0.2-1.i386.rpm
and should fix this problem for good.

Comment 3 Nalin Dahyabhai 2000-02-05 22:17:59 UTC
This bug has been untouched for over two months.  I can only assume Micheal's
suggestion solved the problem.

Comment 4 randolph 2000-02-06 05:01:59 UTC
The base problem is fixed.  *However* rp3-1.0.2-1 no longer asks for
confirmation when I go to start or stop a connection, so apparently a new bug
has been introduced. :(

Comment 5 Nalin Dahyabhai 2000-02-07 12:50:59 UTC
There was some hard-to-reproduce configuration file handling problem with
versions of rp3 up to and including 1.0.6, which I hopefully squashed
before checking 1.0.7 into CVS.  If you can, please try the version from
ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/ and let me know if,
after selecting "Properties..." and checking the confirmation boxes on,
you continue to see this problem.

Comment 6 randolph 2000-02-24 08:39:59 UTC
The configuration file problems are fixed.  However...now when I try to
disconnect, it disconnects and immediately reconnects.  I'm back using
"usernetctl".  Help!
--Randolph

Comment 7 Nalin Dahyabhai 2000-02-29 14:31:59 UTC
Have you applied the ppp errata fix from "http://www.redhat.com/errata/"?  The
double-dial problem is a known bug in the version of the ppp package shipped
the 6.1 release of Red Hat Linux.

Comment 8 randolph 2000-04-28 08:47:59 UTC
With the upgrade to Red Hat 6.2, this bug appears to be gone.  Go ahead and
close it out!

Comment 9 Nalin Dahyabhai 2000-07-13 18:25:41 UTC
What he said....


Note You need to log in before you can comment on or make changes to this bug.