Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6699 - Linuxconf incorrectly limits DHCP subnet address ranges
Summary: Linuxconf incorrectly limits DHCP subnet address ranges
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 6.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-03 23:45 UTC by cac
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-16 17:27:55 UTC


Attachments (Terms of Use)

Description cac 1999-11-03 23:45:11 UTC
linuxconf/Dhcp configuration/one subnet definition

    Network number 172.16.0.0
    netmask 255.255.0.0
    IP range start 176.16.1.0
    IP range stop 176.16.1.255

When accept is clicked, linuxconf reports:

  Invalid host IP number 172.16.1.0

True, this number is an invalid class C address, but it
is a perfectly valid class B address, which is indicated by
the netmask setting.

  Setting the start address to x.x.x.1 and stop address
to x.x.x.254 serve as workarounds.

Comment 1 Riley H Williams 1999-12-16 00:53:59 UTC
It may be a perfectly valid class B address, but it still isn't in the range
you've specified - note your network is *172*.16.* but the address is *176*.16.*
instead...

Comment 2 Riley H Williams 1999-12-16 00:55:59 UTC
Somebody can't type - me !!!

Network is 172.16.*
Range is   176.16.*

172 != 176

Does that help?

Comment 3 Michael K. Johnson 1999-12-16 17:27:59 UTC
rhw is right, this is not a bug.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.