Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6665 - tar fails to properly parse exclude patterns...
Summary: tar fails to properly parse exclude patterns...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tar
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-02 22:28 UTC by bmacy
Modified: 2008-05-01 15:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-18 11:14:33 UTC


Attachments (Terms of Use)

Description bmacy 1999-11-02 22:28:06 UTC
Assuming a /usr/local/src tree exists try:
tar -cvpf fred.tar --exclude='*/src/*' /usr/local

It still archives /usr/local/src. Same occurs if you use
'-X' flag and refer to a file with the pattern in it.

Excluding /usr/local/src/* does work. This is a change from
RedHat versions 5.0, 5.1, 5.2, and 6.0 and appears to be a
bug.

Comment 1 Preston Brown 2000-01-14 03:43:59 UTC
bero, I can verify this, even with tar-1.13.17-1.  Shall we downgrade?

Comment 2 Bernhard Rosenkraenzer 2000-01-18 11:14:59 UTC
I've passed the bug on to bugs-tar@gnu.org - hope they get it fixed for 1.13.18
in time. I don't really want to downgrade because that would get back some bugs
that were fixed in between.

Comment 3 Bernhard Rosenkraenzer 2000-07-17 15:34:03 UTC
The tar maintainers claim it's not a bug, but a feature (better POSIX
compliance).


Note You need to log in before you can comment on or make changes to this bug.