Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 66568 - expected read-only character buffer, int found
Summary: expected read-only character buffer, int found
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 7.3
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-12 11:28 UTC by Christopher Cox
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-06-19 16:13:49 UTC


Attachments (Terms of Use)
Dump the installer provided (deleted)
2002-06-12 11:30 UTC, Christopher Cox
no flags Details

Description Christopher Cox 2002-06-12 11:28:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4) Gecko/20011128
Netscape6/6.2.1

Description of problem:
Intall died right after disk error check.
PII 350, 64M Ram, ATI 3D AGP
Two drives root and /u on hda, /backup and swap on hdc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install->Custom->Everything
2.
3.
	

Additional info:

Comment 1 Christopher Cox 2002-06-12 11:30:09 UTC
Created attachment 60646 [details]
Dump the installer provided

Comment 2 Christopher Cox 2002-06-12 15:31:30 UTC
Moved swap to hda2, problem still occured.

Comment 3 Christopher Cox 2002-06-12 15:31:54 UTC
Moved swap to hda2, problem still occured.

Comment 4 Michael Fulbright 2002-06-12 16:06:26 UTC
Could you try this case w/o turning on bad blocks checking?

Comment 5 Christopher Cox 2002-06-17 15:29:12 UTC
Sorry for the belated response. There was difficulty with the test platform that
was causing lockups during the installation, therefore clouding the issue.

On the new stable platform, the problem persisted and was replicable.
Turning off Bad Block checking did allow the install to proceed without error.


Comment 6 Michael Fulbright 2002-06-17 21:28:26 UTC
This error occurs when the badblocks command detects bad blocks on the system. 
The traceback occurred because the output from the badblocks command has
changed, fooling our parser.

If you get this traceback it means you have bad blocks on the drive it was testing.

In the future an error dialog will be presented saying bad blocks have been
detected.

Comment 7 Michael Fulbright 2002-06-17 21:31:52 UTC

*** This bug has been marked as a duplicate of 66181 ***

Comment 8 Christopher Cox 2002-06-18 11:27:27 UTC
I disagree. The changing of platforms also involved changing hard drives from a
10Gig Maxtor to a new Western Digital 40 Gig WD400BB. 

I doubt very much that both drives have bad blocks. Checkit OK'ed the WD400BB.

Comment 9 Christopher Cox 2002-06-19 16:13:40 UTC
OK close it.

Murphy's law prevails. Purchased yet a third drive and Bad Block Checking did
not crash the install.

Of course there is a problem with your bad block reporting mechanism. 

Thanks and Regards.


Note You need to log in before you can comment on or make changes to this bug.