Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6652 - Invalid /etc/conf.modules file...Finding module dependencies conf:1: missing argument
Summary: Invalid /etc/conf.modules file...Finding module dependencies conf:1: missing ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
: 7422 8587 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-02 17:45 UTC by geimer
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-15 00:41:01 UTC


Attachments (Terms of Use)

Description geimer 1999-11-02 17:45:56 UTC
Hello,

It seems that the 6.1 installer is bugging out for Sound
Blaster CDs. After installing sucessfully, the following
error occurs on boot.

    Finding module dependencies conf:1: missing argument
        can't open.

This results in no kernel modules being loaded (i.e. no
VFAT support, no ethernet, no cdrom, etc.). I found the
problem in the conf.modules file. The installer put the
following line in at the top

    alias sbpcd

When I deleted that line and added the following instead:

    options cdrom sbpcd=1
    alias cdrom sbpcd

Then everything worked fine.

Note, this problem occured with both the original boot
floppy that came with my 6.1 boxed set and the RHEA-1999:045
update disk, using either text install or the gui install
with both the GNU Workstation and a custom install.

Comment 1 Jay Turner 1999-11-03 12:59:59 UTC
This issue has been assigned to a developer for further action.

Comment 2 Anonymous 1999-11-16 21:43:59 UTC
On my particular hardware, conf.modules was setup incorrectly for the sbpcd
module. Entered by the installer as "alias sbpcd". When corrected to "alias
cdrom sbpcd" boot occurred normally.

Comment 3 Bill Nottingham 2000-02-05 07:18:59 UTC
*** Bug 8587 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2000-02-05 07:21:59 UTC
*** Bug 7422 has been marked as a duplicate of this bug. ***

Comment 5 Hans de Goede 2000-02-10 22:57:59 UTC
Still there in beta3

Comment 6 Jay Turner 2000-02-15 00:40:59 UTC
Issue is resolved in next cut of RawHide.

Comment 7 Hans de Goede 2000-03-07 16:03:59 UTC
Confirmed,

But isn't "alias cdrom mcdx" a bogus alias?
And besides that it doesn't add a cdrom entry to /etc/fstab (I'm creating a new
bug for this one)


Note You need to log in before you can comment on or make changes to this bug.