Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6647 - %define and %ifos don't work together
Summary: %define and %ifos don't work together
Keywords:
Status: CLOSED DUPLICATE of bug 5364
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-02 15:52 UTC by luc.maisonobe
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-16 20:24:22 UTC


Attachments (Terms of Use)

Description luc.maisonobe 1999-11-02 15:52:18 UTC
When I used the following lines in a .spec file, the
%{varrotdir} macro is set to /usr/local even on a Linux box.

%ifos Linux
%define varrootdir   /usr
%else
%define varrootdir   /usr/local
%endif

After several trials (%ifos vs %ifnos, Linux vs solaris) it
seems the last alternative is always used, regardless of the
test.

This occurs with rpm 3.0.3.

Comment 1 jbotha 1999-11-02 21:22:59 UTC
This is similar to #5364, i.e. #defines are always executed inside if
statements in the order specified, regardless of whether that part of
the statement should be executed or not.

Comment 2 Jeff Johnson 1999-12-16 20:24:59 UTC
*** This bug has been marked as a duplicate of 5364 ***


Note You need to log in before you can comment on or make changes to this bug.