Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6638 - Init Doesn't Echo Startup messages to terminal
Summary: Init Doesn't Echo Startup messages to terminal
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-02 05:47 UTC by woody
Modified: 2014-03-17 02:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-24 04:33:51 UTC


Attachments (Terms of Use)

Description woody 1999-11-02 05:47:31 UTC
Computer is configured (via lilo boot params) to echo
kernel messages to terminal. This works, but Init (version
2.74) does not echo the nice subsytem startup messages to
the terminal, but instead to tty1, leaving the terminal
looking like the computer has hung, because there is a huge
time gap between the last kernel message (Freed XX Memory)
and the login prompt.

ta.

Comment 1 Bill Nottingham 1999-11-22 16:37:59 UTC
What boot parameters are you using?

Comment 2 woody 1999-11-22 23:57:59 UTC
26 [~]@es-dns (admin)> more /etc/lilo.conf
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
serial=0,9600
append="console=ttyS0,9600n8 console=tty0"
image=/boot/vmlinuz-2.2.5-15
        label=linux
        root=/dev/hda5
        read-only
27 [~]@es-dns (admin)>

Comment 3 Chris Siebenmann 1999-11-23 23:30:59 UTC
This is the unfortunate expected behavior. The problem is that
while LILO and the kernel have a notion of multiple nominal
consoles that can all be active simultaneously, the /dev/console
that program output goes to can only go to one place. One can
send it to the serial port, or to a console screen such as
/dev/tty0, but not both at once.

Comment 4 woody 1999-11-24 05:44:59 UTC
Apparently, the last console given to the kernel is the one that /dev/console
will eventually point to:

i.e.

append="console=ttyS0,9600n8 console=tty0"

and

append="console=tty0 console=ttyS0,9600n8"

give reverse results.


Note You need to log in before you can comment on or make changes to this bug.