Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6633 - ping's return code is always 0
Summary: ping's return code is always 0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netkit-base
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 9296 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-02 01:06 UTC by eugene
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-27 19:44:23 UTC


Attachments (Terms of Use)

Description eugene 1999-11-02 01:06:28 UTC
Even if none of the packets returned, ping still
terminates with 0 error code.
Ex: /bin/ping -c 1 -q 10.1.1.2 (non-existant machine on my
network)
returns 0.
It is a very optimistic ping ;-)

Workaround - get ping from 5.2 (I never tried 6.0)

Comment 1 michael 1999-12-26 19:25:59 UTC
Same for me. RH 6.1, netkit-base-0.10-37.

Just a guess, but this could be caused by ping receiving a "destination
host unreachable", and counts the error packet as a reply packet. From
the manpage:
     If ping does not receive any reply packets at all it will exit with code
     1.  On error it exits with code 2. Otherwise it exits with code 0. This
     makes it possible to use the exit code to see if a host is alive or not.
so this is, technically, behaviour as documented, but is not expected (or
useful).

$ ping -v -c 1 10.42.42.55
PING 10.42.42.55 (10.42.42.55) from 10.42.42.1 : 56(84) bytes of data.
From 10.42.42.1: Destination Host Unreachable
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst Data
 4  5  00 5400 56a3   0 0000  40  01 c76e 10.42.42.1  10.42.42.55

--- 10.42.42.55 ping statistics ---
1 packets transmitted, 0 packets received, +1 errors, 100% packet loss
$ echo $?
0

Comment 2 Jeff Johnson 2000-01-27 19:44:59 UTC
The ping in iputils-991024-2 returns a non-zero return code if host is
unreachable.

Comment 3 Jeff Johnson 2000-02-10 14:24:59 UTC
*** Bug 9296 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.