Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 663 - mc doesnt show the list of files when showing the contents of an RPM
Summary: mc doesnt show the list of files when showing the contents of an RPM
Keywords:
Status: CLOSED DUPLICATE of bug 13
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc
Version: 5.2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-01 18:37 UTC by prabhu
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-01 21:22:22 UTC


Attachments (Terms of Use)

Description prabhu 1999-01-01 18:37:19 UTC
On the mc that ships with RH 5.2 for i386 when one presses
enter on an rpm the contents of the RPM are not properly
shown. Only the ../, /INFO, HEADER, INSTALL and UPGRADE
files show up. None of the actual files installed by the rpm
show up.

	I have actually fixed this bug by editing the file
/usr/lib/mc/extfs/rpm as folows

# diff /usr/lib/mc/extfs/rpm /usr/lib/mc/extfs/rpm~
100c100
<     rpm -qlvp $1 | sed -e 's/^\(..........\)/\1 1 /'
---
>     rpm -qlvp $1 | sed -e 's/^\(..........\)[-t] /\1 1 /'
#

It now works properly.  I do not know whether I should send
this fix as a patch to bugzilla.  Would appreciate any
advice.

prabhu

Comment 1 Jeff Johnson 1999-01-01 21:22:59 UTC
*** This bug has been marked as a duplicate of 13 ***


Note You need to log in before you can comment on or make changes to this bug.