Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 6624 - RFE: Prompt for domain for DNS configuration in GUI
Summary: RFE: Prompt for domain for DNS configuration in GUI
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-02 00:15 UTC by bruce.w.mohler
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-12-19 20:57:54 UTC


Attachments (Terms of Use)

Description bruce.w.mohler 1999-11-02 00:15:30 UTC
At the point where you're entering the the network
configuration, it never prompts for the domain (to be used
as the value of the domain field in the /etc/resolv.conf).
I didn't check the /etc/resolv.conf file to see if there is
a domain line even defined or not.  It was not clear whether
you wanted the user to put in the fully qualified domain
name and let the installer figure out what the hostname and
domain was or what...

By the way, I REALLY like the new GUI.  Keep up the good
work!

Comment 1 Jay Turner 1999-11-30 15:08:59 UTC
This issue has been forwarded to a developer for further action.

Comment 2 Jay Turner 1999-12-06 16:10:59 UTC
*** Bug 6739 has been marked as a duplicate of this bug. ***

Comment 3 Jay Turner 2000-02-09 03:04:59 UTC
Issue has been added to a features list for future releases.

Comment 4 Brent Fox 2000-12-19 18:30:11 UTC
This is more complicated than it might seem.  I think that this will require a
change to the loader as well because of the way the loader passes the hostname
to the second stage installer.  To me, hostname means the machine name without
the domain name.  So, all parts of the installer should be symmetrical...either
ask for hostname and domain name everywhere (loader, GUI, TUI) or just ask for
hostname and domain name together on one line everywhere.

Comment 5 Brent Fox 2000-12-19 18:42:06 UTC
Actually, the loader does not need to be changed.

Comment 6 Brent Fox 2000-12-19 19:24:56 UTC
Fixed in CVS.  This was easier than I thought.  This problem still exists in
text mode, but that's another issue that I'll look at later.  
Brock, please verify that this has been implemented correctly.

Comment 7 Brent Fox 2000-12-19 20:58:42 UTC
Actually, I have been informed that the hostname entry should always accept a
fully qualified domain name, so I backed out the changes.


Note You need to log in before you can comment on or make changes to this bug.